package/civetweb: fix link failure due to missing OpenSSL dependency
authorGiulio Benetti <giulio.benetti@micronovasrl.com>
Tue, 9 Apr 2019 21:10:32 +0000 (23:10 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 9 Apr 2019 21:26:21 +0000 (23:26 +0200)
During linking one OpenSSL dependecy is missing(-latomic) on linking
library list.

- Substitute explicit library list with `pkg-config libssl` when
  BR2_PACKAGE_OPENSSL is enabled. In such way all needed libraries
  will be included in linking list.

- Add also `host-pkgconf` to CIVETWEB_DEPENDENCIES if
  BR2_PACKAGE_OPENSSL is enabled to make it available for previous
  point.

Fixes:

  http://autobuild.buildroot.net/results/b2e210bdefe84f4ec9cfda79a33d81788fb7e66c/

Signed-off-by: Giulio Benetti <giulio.benetti@micronovasrl.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/civetweb/civetweb.mk

index fe1cdd5675ac1d6887b7e80b9baa0b26ce088a7f..80272738e4a15391e5ec2b0d0154c1de49e2f42d 100644 (file)
@@ -32,8 +32,8 @@ endif
 
 ifeq ($(BR2_PACKAGE_OPENSSL),y)
 CIVETWEB_COPT += -DNO_SSL_DL
-CIVETWEB_LIBS += -lssl -lcrypto -lz
-CIVETWEB_DEPENDENCIES += openssl
+CIVETWEB_LIBS += `$(PKG_CONFIG_HOST_BINARY) --libs libssl`
+CIVETWEB_DEPENDENCIES += openssl host-pkgconf
 else
 CIVETWEB_COPT += -DNO_SSL
 endif