gettext: disable tools tests when no threads
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Sat, 22 Dec 2012 02:31:02 +0000 (02:31 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 23 Dec 2012 07:37:44 +0000 (08:37 +0100)
Disable the gettext-tools tests build since they break when a full
toolchain without threads is being used.
Fixes:
http://autobuild.buildroot.net/results/a187c76c359787f8e2ec6e12da2d7b1e33ed43c5/

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/gettext/gettext.mk

index 77881d3e3495c0eb9b2d69ec2883602cdca740f0..a91cb7f1f7108c18276be8031e7e5dfb0a29eb44 100644 (file)
@@ -44,6 +44,12 @@ define GETTEXT_DISABLE_TOOLS
 endef
 endif # GETTEXT_TOOLS = n
 
+# The tools tests build fails with full toolchain without threads
+define GETTEXT_DISABLE_TESTS
+       $(SED) 's/m4 tests/m4/' $(@D)/gettext-tools/Makefile.in
+endef
+
 GETTEXT_POST_PATCH_HOOKS += GETTEXT_DISABLE_TOOLS
+GETTEXT_POST_PATCH_HOOKS += GETTEXT_DISABLE_TESTS
 
 $(eval $(autotools-package))