lcdproc: bump to version 0.5.9
authorSven Haardiek <sven.haardiek@greenbone.net>
Wed, 6 Sep 2017 14:48:55 +0000 (16:48 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 6 Sep 2017 20:57:14 +0000 (22:57 +0200)
This commit bumps lcdproc to version 0.5.9, and switches to the new
upstream on github.

The new version also compiles with musl without any patches.

Signed-off-by: Sven Haardiek <sven.haardiek@greenbone.net>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/lcdproc/0002-musl.patch [deleted file]
package/lcdproc/lcdproc.hash
package/lcdproc/lcdproc.mk

diff --git a/package/lcdproc/0002-musl.patch b/package/lcdproc/0002-musl.patch
deleted file mode 100644 (file)
index d0425fd..0000000
+++ /dev/null
@@ -1,102 +0,0 @@
-Fix musl build
-
-Partly downloaded from
-http://lists.omnipotent.net/pipermail/lcdproc/2015-November/014291.html
-http://lists.omnipotent.net/pipermail/lcdproc/2015-November/014281.html
-
-Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
-
-diff -uNr lcdproc-0.5.7.org/clients/lcdproc/machine.h lcdproc-0.5.7/clients/lcdproc/machine.h
---- lcdproc-0.5.7.org/clients/lcdproc/machine.h        2012-08-19 16:29:07.000000000 +0200
-+++ lcdproc-0.5.7/clients/lcdproc/machine.h    2016-01-30 14:07:33.641802847 +0100
-@@ -12,6 +12,7 @@
- #ifndef _lcdproc_machine_h_
- #define _lcdproc_machine_h_
-+#include <time.h>
- #include "shared/LL.h"
- #ifndef LOADAVG_NSTATS
-diff -uNr lcdproc-0.5.7.org/server/drivers/hd44780-pifacecad.c lcdproc-0.5.7/server/drivers/hd44780-pifacecad.c
---- lcdproc-0.5.7.org/server/drivers/hd44780-pifacecad.c       2014-03-23 11:22:09.000000000 +0100
-+++ lcdproc-0.5.7/server/drivers/hd44780-pifacecad.c   2016-01-30 14:12:03.521279729 +0100
-@@ -54,6 +54,7 @@
- #include <unistd.h>
- #include <fcntl.h>
- #include <sys/ioctl.h>
-+#include <linux/ioctl.h>
- #include <stdint.h>
- #include <linux/spi/spidev.h>
-diff -uNr lcdproc-0.5.7.org/server/drivers/hd44780-rpi.c lcdproc-0.5.7/server/drivers/hd44780-rpi.c
---- lcdproc-0.5.7.org/server/drivers/hd44780-rpi.c     2014-03-23 11:22:09.000000000 +0100
-+++ lcdproc-0.5.7/server/drivers/hd44780-rpi.c 2016-01-30 14:04:10.288112853 +0100
-@@ -285,7 +285,7 @@
-       /* Unmap and free memory */
-       if (gpio_map != NULL)
--              munmap((caddr_t) gpio_map, GPIO_BLOCK_SIZE);
-+              munmap((void *) gpio_map, GPIO_BLOCK_SIZE);
-       if (p->rpi_gpio != NULL)
-               free(p->rpi_gpio);
-       p->rpi_gpio = NULL;
-diff -uNr lcdproc-0.5.7.org/server/drivers/hd44780-spi.c lcdproc-0.5.7/server/drivers/hd44780-spi.c
---- lcdproc-0.5.7.org/server/drivers/hd44780-spi.c     2014-03-23 11:22:09.000000000 +0100
-+++ lcdproc-0.5.7/server/drivers/hd44780-spi.c 2016-01-30 14:11:11.604763500 +0100
-@@ -29,6 +29,7 @@
- #include <unistd.h>
- #include <fcntl.h>
- #include <sys/ioctl.h>
-+#include <linux/ioctl.h>
- #include <stdint.h>
- #include <linux/spi/spidev.h>
-diff -uNr lcdproc-0.5.7.org/server/drivers/mtc_s16209x.c lcdproc-0.5.7/server/drivers/mtc_s16209x.c
---- lcdproc-0.5.7.org/server/drivers/mtc_s16209x.c     2011-08-14 14:29:16.000000000 +0200
-+++ lcdproc-0.5.7/server/drivers/mtc_s16209x.c 2016-01-30 14:13:10.691122839 +0100
-@@ -49,6 +49,7 @@
- #include <fcntl.h>
- #include <string.h>
- #include <errno.h>
-+#include <sys/file.h>
- #ifdef HAVE_CONFIG_H
- # include "config.h"
-diff -uNr lcdproc-0.5.7.org/server/drivers/rawserial.c lcdproc-0.5.7/server/drivers/rawserial.c
---- lcdproc-0.5.7.org/server/drivers/rawserial.c       2014-03-23 11:22:10.000000000 +0100
-+++ lcdproc-0.5.7/server/drivers/rawserial.c   2016-01-30 14:03:43.465779507 +0100
-@@ -60,13 +60,13 @@
-       /** \name Event loop timing. refresh_time and refresh_delta form the
-        * event loop timing mechanism for configurable update rates.
-        *@{*/
--      uint refresh_time;              /**< time at the last screen update */
--      uint refresh_delta;             /**< time step to next screen update */
-+      unsigned int refresh_time;              /**< time at the last screen update */
-+      unsigned int refresh_delta;             /**< time step to next screen update */
-       /**@}*/
- } PrivateData;
- /* Local prototypes */
--static uint get_millisecond_time(void);
-+static unsigned int get_millisecond_time(void);
- /* Vars for the server core */
-@@ -303,7 +303,7 @@
-       PrivateData *p = drvthis->private_data;
-       char out[LCD_MAX_WIDTH * LCD_MAX_HEIGHT];
--      uint currentTime = get_millisecond_time();
-+      unsigned int currentTime = get_millisecond_time();
-       int t_delta = currentTime - p->refresh_time;
-       /*
-@@ -415,7 +415,7 @@
-  *
-  * \return  int with current millisecond time.
-  */
--static uint
-+static unsigned int
- get_millisecond_time(void)
- {
-       struct timeval ts;
index ea39a9b49233a162e8ad9b101c3e1cfd5f35b595..00f685448da7e23a99f270d1fcdd2f304108bbe1 100644 (file)
@@ -1,2 +1,3 @@
 # Locally computed:
 sha256  843007d377adc856529ed0c7c42c9a7563043f06b1b73add0372bba3a3029804  lcdproc-0.5.7.tar.gz
+sha256  d48a915496c96ff775b377d2222de3150ae5172bfb84a6ec9f9ceab962f97b83  lcdproc-0.5.9.tar.gz
index e602088fa81a98fdf7765e40ac1c3e0686c5464c..e5b6172b15a48c31cd3e3a5cc2516d8f477ef743 100644 (file)
@@ -4,8 +4,8 @@
 #
 ################################################################################
 
-LCDPROC_VERSION = 0.5.7
-LCDPROC_SITE = http://downloads.sourceforge.net/project/lcdproc/lcdproc/$(LCDPROC_VERSION)
+LCDPROC_VERSION = 0.5.9
+LCDPROC_SITE = https://github.com/lcdproc/lcdproc/releases/download/v$(LCDPROC_VERSION)
 LCDPROC_LICENSE = GPL-2.0+
 LCDPROC_LICENSE_FILES = COPYING
 LCDPROC_MAKE = $(MAKE1)