package/qpdf: New package qpdf 5.1.2
authorOlivier Schonken <olivier.schonken@gmail.com>
Sun, 22 Mar 2015 21:12:50 +0000 (23:12 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 4 Apr 2015 09:59:42 +0000 (11:59 +0200)
[Thomas:
  - adjust length of comment header in .mk file.
  - fix comment in Config.in to match what's specific in the Buildroot
    manual.
  - fix <pkg>_LICENSE to 'Artistic-2.0'.]

Signed-off-by: Olivier Schonken <olivier.schonken@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/qpdf/Config.in [new file with mode: 0644]
package/qpdf/qpdf.hash [new file with mode: 0644]
package/qpdf/qpdf.mk [new file with mode: 0644]

index 3f670f3e8dd7675cb1827f4d3e3a2f458cc1636a..89bed0d4476a1eb94026d4a71e6e3fa1afff023f 100644 (file)
@@ -1077,6 +1077,7 @@ menu "Miscellaneous"
        source "package/haveged/Config.in"
        source "package/mcrypt/Config.in"
        source "package/mobile-broadband-provider-info/Config.in"
+       source "package/qpdf/Config.in"
        source "package/qemu/Config.in"
        source "package/shared-mime-info/Config.in"
        source "package/snowball-init/Config.in"
diff --git a/package/qpdf/Config.in b/package/qpdf/Config.in
new file mode 100644 (file)
index 0000000..e8ab9ba
--- /dev/null
@@ -0,0 +1,17 @@
+config BR2_PACKAGE_QPDF
+       bool "qpdf"
+       depends on BR2_INSTALL_LIBSTDCPP
+       select BR2_PACKAGE_PCRE
+       select BR2_PACKAGE_ZLIB
+       help
+         QPDF is a command-line program that does structural, content-
+         preserving transformations on PDF files. It could have been called
+         something like pdf-to-pdf. It also provides many useful capabilities
+         to developers of PDF-producing software or for people who just want
+         to look at the innards of a PDF file to learn more about how they
+         work.
+
+         http://qpdf.sourceforge.net/
+
+comment "qpdf needs a toolchain w/ C++"
+       depends on !BR2_INSTALL_LIBSTDCPP
diff --git a/package/qpdf/qpdf.hash b/package/qpdf/qpdf.hash
new file mode 100644 (file)
index 0000000..c6c6ebe
--- /dev/null
@@ -0,0 +1,2 @@
+# Downloaded from http://sourceforge.net/projects/qpdf/files/qpdf/5.1.2/
+md5    0bd15ef5eea5f628951ab456c84e78ec  qpdf-5.1.2.tar.gz
diff --git a/package/qpdf/qpdf.mk b/package/qpdf/qpdf.mk
new file mode 100644 (file)
index 0000000..bfd533c
--- /dev/null
@@ -0,0 +1,16 @@
+################################################################################
+#
+# qpdf
+#
+################################################################################
+
+QPDF_VERSION = 5.1.2
+QPDF_SITE = http://downloads.sourceforge.net/project/qpdf/qpdf/$(QPDF_VERSION)
+QPDF_INSTALL_STAGING = YES
+QPDF_LICENSE = Artistic-2.0
+QPDF_LICENSE_FILES = Artistic-2.0
+QPDF_DEPENDENCIES = pcre zlib
+
+QPDF_CONF_OPTS = --without-random
+
+$(eval $(autotools-package))