libarchive: add host variant
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 12 Jun 2016 21:10:38 +0000 (23:10 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 12 Jun 2016 21:10:38 +0000 (23:10 +0200)
This will be needed for the host variant of the fwup package. We enable
zlib support since host-fwup needs it. All other features are explicitly
disabled.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libarchive/libarchive.mk

index 726142b217daf11b3a531bf9b5bdd3c9eeb93a9d..e20a737d6aa3f1502b0ca46f691b2a6096ded389 100644 (file)
@@ -99,4 +99,21 @@ else
 LIBARCHIVE_CONF_OPTS += --without-lzma
 endif
 
+# The only user of host-libarchive needs zlib support
+HOST_LIBARCHIVE_DEPENDENCIES = host-zlib
+HOST_LIBARCHIVE_CONF_OPTS = \
+       --disable-bsdtar \
+       --disable-bsdcpio \
+       --disable-acl \
+       --disable-xattr \
+       --without-bz2lib \
+       --without-expat \
+       --without-libiconv-prefix \
+       --without-xml2 \
+       --without-lzo2 \
+       --without-nettle \
+       --without-openssl \
+       --without-lzma
+
 $(eval $(autotools-package))
+$(eval $(host-autotools-package))