package/vlc: add optional dependency to libsecret
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 12 Aug 2018 20:29:30 +0000 (22:29 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 16 Aug 2018 11:36:38 +0000 (13:36 +0200)
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/vlc/vlc.mk

index fab08b950d0f7419fb127e2de5f7a3d6e8d8d824..f777d86bda789aedd12e8a52e3b3573901e33ee4 100644 (file)
@@ -74,7 +74,6 @@ VLC_CONF_OPTS += \
        --disable-notify \
        --disable-projectm \
        --disable-schroedinger \
-       --disable-secret \
        --disable-soxr \
        --disable-shine \
        --disable-shout \
@@ -338,6 +337,13 @@ else
 VLC_CONF_OPTS += --disable-samplerate
 endif
 
+ifeq ($(BR2_PACKAGE_LIBSECRET),y)
+VLC_CONF_OPTS += --enable-secret
+VLC_DEPENDENCIES += libsecret
+else
+VLC_CONF_OPTS += --disable-secret
+endif
+
 ifeq ($(BR2_PACKAGE_LIBSSH2),y)
 VLC_CONF_OPTS += --enable-sftp
 VLC_DEPENDENCIES += libssh2