* Fixed bash patches
authorNigel Kukard <nkukard@lbsd.net>
Thu, 1 May 2008 19:07:58 +0000 (19:07 -0000)
committerNigel Kukard <nkukard@lbsd.net>
Thu, 1 May 2008 19:07:58 +0000 (19:07 -0000)
package/bash/bash32-025
package/bash/bash32-026
package/bash/bash32-027
package/bash/bash32-028
package/bash/bash32-029
package/bash/bash32-030
package/bash/bash32-031
package/bash/bash32-032
package/bash/bash32-033

index 4d53d89d73e86c685be16764edcaca823a297220..20f86074da2bd9a3422e75dfd48b0ada9c196373 100644 (file)
@@ -16,8 +16,8 @@ of data into a terminal window).
 
 Patch:
 
-*** ../bash-3.2-patched/lib/readline/input.c   Wed Aug 16 15:15:16 2006
---- lib/readline/input.c       Tue Jul 17 09:24:21 2007
+*** bash-3.2-patched/lib/readline/input.c      Wed Aug 16 15:15:16 2006
+--- bash-3.2/lib/readline/input.c      Tue Jul 17 09:24:21 2007
 ***************
 *** 134,139 ****
   
@@ -62,8 +62,8 @@ Patch:
 + #endif
       push_index = 0;
   
-*** ../bash-3.2/patchlevel.h   Thu Apr 13 08:31:04 2006
---- patchlevel.h       Mon Oct 16 14:22:54 2006
+*** bash-3.2/patchlevel.h      Thu Apr 13 08:31:04 2006
+--- bash-3.2/patchlevel.h      Mon Oct 16 14:22:54 2006
 ***************
 *** 26,30 ****
      looks for to find the patch level (for the sccs version string). */
index ba7de50a8dd23b2b33e733564645fc1edd27b82d..8e7c2bdf12a16f6f29c6da54424f021162687003 100644 (file)
@@ -22,8 +22,8 @@ bash.
 
 Patch:
 
-*** ../bash-3.2-patched/configure.in   2007-03-06 11:07:38.000000000 -0500
---- configure.in       2007-11-23 15:37:41.000000000 -0500
+*** bash-3.2-patched/configure.in      2007-03-06 11:07:38.000000000 -0500
+--- bash-3.2/configure.in      2007-11-23 15:37:41.000000000 -0500
 ***************
 *** 519,523 ****
                # dynamic version
@@ -37,8 +37,8 @@ Patch:
 !              darwin[[89]]*)  READLINE_LIB='${READLINE_LIBRARY}' ;;
                *)              READLINE_LIB=-lreadline ;;
                esac
-*** ../bash-3.2-patched/configure      2007-03-24 14:51:22.000000000 -0400
---- configure  2007-11-23 15:46:15.000000000 -0500
+*** bash-3.2-patched/configure 2007-03-24 14:51:22.000000000 -0400
+--- bash-3.2/configure 2007-11-23 15:46:15.000000000 -0500
 ***************
 *** 4872,4876 ****
                # dynamic version
@@ -52,8 +52,8 @@ Patch:
 !              darwin[89]*)    READLINE_LIB='${READLINE_LIBRARY}' ;;
                *)              READLINE_LIB=-lreadline ;;
                esac
-*** ../bash-3.2-patched/version.c      2005-05-16 11:58:34.000000000 -0400
---- version.c  2007-11-23 16:03:40.000000000 -0500
+*** bash-3.2-patched/version.c 2005-05-16 11:58:34.000000000 -0400
+--- bash-3.2/version.c 2007-11-23 16:03:40.000000000 -0500
 ***************
 *** 80,83 ****
     printf ("GNU bash, version %s (%s)\n", shell_version_string (), MACHTYPE);
@@ -65,8 +65,8 @@ Patch:
     if (extended)
 !     printf (_("Copyright (C) 2007 Free Software Foundation, Inc.\n"));
   }
-*** ../bash-3.2/patchlevel.h   Thu Apr 13 08:31:04 2006
---- patchlevel.h       Mon Oct 16 14:22:54 2006
+*** bash-3.2/patchlevel.h      Thu Apr 13 08:31:04 2006
+--- bash-3.2/patchlevel.h      Mon Oct 16 14:22:54 2006
 ***************
 *** 26,30 ****
      looks for to find the patch level (for the sccs version string). */
index 5e110cb96ff736ec0bb269aa5ab6bcdecad66c91..289914cfd52f259d804de22bf419555f3026164c 100644 (file)
@@ -16,8 +16,8 @@ prompt contains invisible characters and a newline.
 
 Patch:
 
-*** ../bash-3.2.25/lib/readline/display.c      Mon Aug  6 14:26:29 2007
---- lib/readline/display.c     Wed Oct 10 22:43:58 2007
+*** bash-3.2.25/lib/readline/display.c Mon Aug  6 14:26:29 2007
+--- bash-3.2/lib/readline/display.c    Wed Oct 10 22:43:58 2007
 ***************
 *** 1049,1053 ****
              else
@@ -68,8 +68,8 @@ Patch:
 !       _rl_last_c_pos == prompt_physical_chars)
       cpos_adjusted = 1;
   #endif
-*** ../bash-3.2/patchlevel.h   Thu Apr 13 08:31:04 2006
---- patchlevel.h       Mon Oct 16 14:22:54 2006
+*** bash-3.2/patchlevel.h      Thu Apr 13 08:31:04 2006
+--- bash-3.2/patchlevel.h      Mon Oct 16 14:22:54 2006
 ***************
 *** 26,30 ****
      looks for to find the patch level (for the sccs version string). */
index e8182948d6d87c88c3bd812289f4a5d912de7283..661c53827f639217bdd1aae41007c2841407b1af 100644 (file)
@@ -15,8 +15,8 @@ containing invisible characters after the final newline.
 
 Patch:
 
-*** ../bash-3.2-patched/lib/readline/display.c 2007-08-25 13:47:08.000000000 -0400
---- lib/readline/display.c     2007-11-10 17:51:29.000000000 -0500
+*** bash-3.2-patched/lib/readline/display.c    2007-08-25 13:47:08.000000000 -0400
+--- bash-3.2/lib/readline/display.c    2007-11-10 17:51:29.000000000 -0500
 ***************
 *** 392,396 ****
         local_prompt = expand_prompt (p, &prompt_visible_length,
@@ -43,8 +43,8 @@ Patch:
 !                                                 (int *)NULL,
                                                   (int *)NULL);
         *t = c;
-*** ../bash-3.2/patchlevel.h   Thu Apr 13 08:31:04 2006
---- patchlevel.h       Mon Oct 16 14:22:54 2006
+*** bash-3.2/patchlevel.h      Thu Apr 13 08:31:04 2006
+--- bash-3.2/patchlevel.h      Mon Oct 16 14:22:54 2006
 ***************
 *** 26,30 ****
      looks for to find the patch level (for the sccs version string). */
index 9de208584f3fb4b620a25d6f3a9512e0d7a5d067..34c84f139d868d472318b124110077b0606cc517 100644 (file)
@@ -16,8 +16,8 @@ operator, and an error occurs, evaluation is not re-enabled.
 
 Patch:
 
-*** ../bash-3.2-patched/expr.c 2007-08-25 13:47:05.000000000 -0400
---- expr.c     2007-10-18 08:08:44.000000000 -0400
+*** bash-3.2-patched/expr.c    2007-08-25 13:47:05.000000000 -0400
+--- bash-3.2/expr.c    2007-10-18 08:08:44.000000000 -0400
 ***************
 *** 287,290 ****
 --- 287,292 ----
@@ -35,8 +35,8 @@ Patch:
 +   noeval = 0;
   
     FASTCOPY (evalbuf, oevalbuf, sizeof (evalbuf));
-*** ../bash-3.2/patchlevel.h   Thu Apr 13 08:31:04 2006
---- patchlevel.h       Mon Oct 16 14:22:54 2006
+*** bash-3.2/patchlevel.h      Thu Apr 13 08:31:04 2006
+--- bash-3.2/patchlevel.h      Mon Oct 16 14:22:54 2006
 ***************
 *** 26,30 ****
      looks for to find the patch level (for the sccs version string). */
index 3f12c2833cf228099344dd5969900ac508e231cf..dc7792155053e497bddc7d8600220eb9c818dc37 100644 (file)
@@ -16,8 +16,8 @@ first in a sequential list.
 
 Patch:
 
-*** ../bash-3.2-patched/execute_cmd.c  2007-03-24 14:51:05.000000000 -0400
---- execute_cmd.c      2007-11-05 22:31:14.000000000 -0500
+*** bash-3.2-patched/execute_cmd.c     2007-03-24 14:51:05.000000000 -0400
+--- bash-3.2/execute_cmd.c     2007-11-05 22:31:14.000000000 -0500
 ***************
 *** 615,619 ****
         redirection_undo_list = (REDIRECT *)NULL;
@@ -31,8 +31,8 @@ Patch:
 !       return (last_command_exit_value = EXECUTION_FAILURE);
       }
 
-*** ../bash-3.2/patchlevel.h   Thu Apr 13 08:31:04 2006
---- patchlevel.h       Mon Oct 16 14:22:54 2006
+*** bash-3.2/patchlevel.h      Thu Apr 13 08:31:04 2006
+--- bash-3.2/patchlevel.h      Mon Oct 16 14:22:54 2006
 ***************
 *** 26,30 ****
      looks for to find the patch level (for the sccs version string). */
index 6c96fb9d0a06132958d8f084863a80591599fe5b..f025da3818af9d4d600824038e2ed4fae03c52d2 100644 (file)
@@ -17,8 +17,8 @@ text being drawn begins before the last invisible character in the line.
 
 Patch:
 
-*** ../bash-3.2-patched/lib/readline/display.c 2007-08-25 13:47:08.000000000 -0400
---- lib/readline/display.c     2007-11-10 17:51:29.000000000 -0500
+*** bash-3.2-patched/lib/readline/display.c    2007-08-25 13:47:08.000000000 -0400
+--- bash-3.2/lib/readline/display.c    2007-11-10 17:51:29.000000000 -0500
 ***************
 *** 1566,1574 ****
          else
@@ -45,8 +45,8 @@ Patch:
 +              }
              return;
            }
-*** ../bash-3.2/patchlevel.h   Thu Apr 13 08:31:04 2006
---- patchlevel.h       Mon Oct 16 14:22:54 2006
+*** bash-3.2/patchlevel.h      Thu Apr 13 08:31:04 2006
+--- bash-3.2/patchlevel.h      Mon Oct 16 14:22:54 2006
 ***************
 *** 26,30 ****
      looks for to find the patch level (for the sccs version string). */
index 5e53e29198cd3176d9f186b0ef3eaedfd43b6f02..bce4c23e6204a8321e962ba3405223abdf8cf81e 100644 (file)
@@ -15,8 +15,8 @@ very quickly in succession, causing characters to be dropped.
 
 Patch:
 
-*** ../bash-3.2-patched/lib/readline/input.c   2007-08-25 13:47:10.000000000 -0400
---- lib/readline/input.c       2007-10-12 22:55:25.000000000 -0400
+*** bash-3.2-patched/lib/readline/input.c      2007-08-25 13:47:10.000000000 -0400
+--- bash-3.2/lib/readline/input.c      2007-10-12 22:55:25.000000000 -0400
 ***************
 *** 155,159 ****
         pop_index--;
@@ -30,8 +30,8 @@ Patch:
 !      pop_index = ibuffer_len;
         ibuffer[pop_index] = key;
         return (1);
-*** ../bash-3.2/patchlevel.h   Thu Apr 13 08:31:04 2006
---- patchlevel.h       Mon Oct 16 14:22:54 2006
+*** bash-3.2/patchlevel.h      Thu Apr 13 08:31:04 2006
+--- bash-3.2/patchlevel.h      Mon Oct 16 14:22:54 2006
 ***************
 *** 26,30 ****
      looks for to find the patch level (for the sccs version string). */
index 0d698108ba048e3ef6ad3ddf6f3b2bbb7db99425..89bc35d625721e1bfb48d2262ce290f53dcc0fed 100644 (file)
@@ -16,8 +16,8 @@ ASCII 127 characters in the expanded value.
 
 Patch:
 
-*** ../bash-3.2-patched/arrayfunc.c    2007-08-25 13:47:05.000000000 -0400
---- arrayfunc.c        2007-05-31 11:55:46.000000000 -0400
+*** bash-3.2-patched/arrayfunc.c       2007-08-25 13:47:05.000000000 -0400
+--- bash-3.2/arrayfunc.c       2007-05-31 11:55:46.000000000 -0400
 ***************
 *** 723,727 ****
       {
@@ -31,8 +31,8 @@ Patch:
 !      *rtype = (t[0] == '*') ? 1 : 2;
         if (allow_all == 0)
        {
-*** ../bash-3.2-patched/subst.c        2007-08-25 13:47:08.000000000 -0400
---- subst.c    2007-11-14 15:43:00.000000000 -0500
+*** bash-3.2-patched/subst.c   2007-08-25 13:47:08.000000000 -0400
+--- bash-3.2/subst.c   2007-11-14 15:43:00.000000000 -0500
 ***************
 *** 4908,4915 ****
     intmax_t arg_index;
@@ -70,8 +70,8 @@ Patch:
 +       ret->flags |= rflags;
       }
     return ret;
-*** ../bash-3.2/patchlevel.h   Thu Apr 13 08:31:04 2006
---- patchlevel.h       Mon Oct 16 14:22:54 2006
+*** bash-3.2/patchlevel.h      Thu Apr 13 08:31:04 2006
+--- bash-3.2/patchlevel.h      Mon Oct 16 14:22:54 2006
 ***************
 *** 26,30 ****
      looks for to find the patch level (for the sccs version string). */