uboot: add option to optionally depend on host-openssl
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 16 Oct 2016 07:42:22 +0000 (09:42 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 20 Oct 2016 21:31:09 +0000 (23:31 +0200)
Some U-Boot board configurations have CONFIG_FIT_SIGNATURE=y. In this
case, when U-Boot builds its tools, it requires OpenSSL support on the
host system.

Since we clearly don't want to unconditionally depend on host-openssl,
we introduce a new option to explicitly enable the dependency on
host-openssl. This is exactly identical to the existing
BR2_TARGET_UBOOT_NEEDS_DTC, for the dependency on host-dtc. It is
therefore the responsibility of the user to enable this option if his
board configuration uses CONFIG_FIT_SIGNATURE=y.

Necessary to fix bug #9316.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
boot/uboot/Config.in
boot/uboot/uboot.mk

index d46a757680988a9439fdde2d6a978dc2d58b8598..fabf27db73cd2e301a721ac1453815ddc4fe2451 100644 (file)
@@ -137,6 +137,14 @@ config BR2_TARGET_UBOOT_NEEDS_DTC
          Select this option if your U-Boot board configuration
          requires the Device Tree compiler to be available.
 
+config BR2_TARGET_UBOOT_NEEDS_OPENSSL
+       bool "U-Boot needs OpenSSL"
+       help
+         Select this option if your U-Boot board configuration
+         requires OpenSSL to be available on the host. This is
+         typically the case when the board configuration has
+         CONFIG_FIT_SIGNATURE enabled.
+
 menu "U-Boot binary format"
 
 config BR2_TARGET_UBOOT_FORMAT_AIS
index 86e5b84d901eecddbeb499a136176e987e19aa4c..ae7539d512a625c8093fad2911937460f2957d9a 100644 (file)
@@ -133,6 +133,10 @@ ifeq ($(BR2_TARGET_UBOOT_NEEDS_DTC),y)
 UBOOT_DEPENDENCIES += host-dtc
 endif
 
+ifeq ($(BR2_TARGET_UBOOT_NEEDS_OPENSSL),y)
+UBOOT_DEPENDENCIES += host-openssl
+endif
+
 # prior to u-boot 2013.10 the license info was in COPYING. Copy it so
 # legal-info finds it
 define UBOOT_COPY_OLD_LICENSE_FILE