lua: fix build issue with gcc 4.6
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 20 Jul 2012 16:55:23 +0000 (18:55 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 20 Jul 2012 18:03:52 +0000 (20:03 +0200)
gcc 4.6 has become more sensitive about option ordering, especially
libraries. It requires the -l flags to be placed after the object
files that need that library. See for example
http://nick.zoic.org/art/etc/gcc-linker-libs.html. We had -llua at the
beginning of the link command line, causing build issues (here on gcc
4.6 with host-lua).

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/lua/lua-02-shared-libs-for-lua.patch
package/lua/lua-03-shared-libs-for-luac.patch

index afe2ac89414952e84a80495f35925f1061c96771..454e660024f165b04b2cb53f156c3f053ad91439 100644 (file)
@@ -43,7 +43,7 @@ Index: b/src/Makefile
 +      ln -fs $@.$(PKG_VERSION) $@
 +
 +$(LUA_T): $(LUA_O) $(LUA_SO)
-+      $(CC) -o $@ -L. -llua $(MYLDFLAGS) $(LUA_O) $(LIBS)
++      $(CC) -o $@ -L. $(MYLDFLAGS) $(LUA_O) -llua $(LIBS)
  
  $(LUAC_T): $(LUAC_O) $(LUA_A)
        $(CC) -o $@ $(MYLDFLAGS) $(LUAC_O) $(LUA_A) $(LIBS)
index ebe5337afb387de5d8e4e321761a9fc933ea3f97..33f9183bb5eeedfdd1542263b6e612199e598283 100644 (file)
@@ -91,7 +91,7 @@ Index: b/src/Makefile
 -$(LUAC_T): $(LUAC_O) $(LUA_A)
 -      $(CC) -o $@ $(MYLDFLAGS) $(LUAC_O) $(LUA_A) $(LIBS)
 +$(LUAC_T): $(LUAC_O) $(LUA_SO)
-+      $(CC) -o $@ -L. -llua $(MYLDFLAGS) $(LUAC_O) $(LIBS)
++      $(CC) -o $@ -L. $(MYLDFLAGS) $(LUAC_O) -llua $(LIBS)
  
  clean:
        $(RM) $(ALL_T) $(ALL_O)