External toolchain C++ cross-compiler fix
authorPeter Korsgaard <jacmet@sunsite.dk>
Mon, 3 Nov 2008 10:37:27 +0000 (10:37 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 3 Nov 2008 10:37:27 +0000 (10:37 -0000)
External toolchain C++ cross-compiler fix

package/Makefile.in resets CXX to "" in TARGET_CONFIGURE_OPTS if
BR2_GCC_CROSS_CXX is not set to 'y'. However, when using an external
toolchain, BR2_GCC_CROSS_CXX is not set even if the toolchain has a
C++ cross-compiler.

This patch adds a new BR2_GCC_CROSS_CXX option in the external
toolchain configuration menu, so that just like BR2_INET_RPC,
BR2_INET_IPV6 and the others, it can be set according to the external
toolchain configuration.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
toolchain/external-toolchain/Config.in

index 805d21a2c5ee02bc87f4a554c27d96d1dfd076c5..6c957bc9b36f39cfe43486dcfc807bc2f92e499b 100644 (file)
@@ -93,6 +93,12 @@ config BR2_SOFT_FLOAT
        help
          Set this option if the external toolchain supports soft float.
 
+config BR2_GCC_CROSS_CXX
+       bool "Toolchain has C++ cross-compiler ?"
+       help
+         Set this option if the external toolchain has a C++
+         cross-compiler.
+
 config BR2_TARGET_OPTIMIZATION
        string "Target Optimizations"
        default "-Os -pipe"