package/gst1-plugins-bad: add zbar plugin option
authorPeter Seiderer <ps.report@gmx.net>
Sat, 9 Mar 2019 21:50:36 +0000 (22:50 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 12 Mar 2019 22:11:53 +0000 (23:11 +0100)
Signed-off-by: Peter Seiderer <ps.report@gmx.net>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/gstreamer1/gst1-plugins-bad/Config.in
package/gstreamer1/gst1-plugins-bad/gst1-plugins-bad.mk

index a2ceeb90350a90fa23e18d77c7cb27219469d9c2..869f0a9d45ce751ad16f08089a3bde5a132c6905 100644 (file)
@@ -587,4 +587,17 @@ config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_X265
 comment "x265 needs a toolchain w/ C++, dynamic library"
        depends on !BR2_INSTALL_LIBSTDCPP || BR2_STATIC_LIBS
 
+config BR2_PACKAGE_GST1_PLUGINS_BAD_ZBAR
+       bool "zbar"
+       depends on BR2_TOOLCHAIN_HAS_THREADS # zbar-> libv4l
+       depends on BR2_USE_MMU # zbar-> libv4l
+       depends on BR2_INSTALL_LIBSTDCPP # zbar-> libv4l
+       depends on BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_0 # zbar -> libv4l
+       select BR2_PACKAGE_ZBAR
+
+comment "zbar plugin needs a toolchain w/ threads, C++ and headers >= 3.0"
+       depends on BR2_USE_MMU
+       depends on !BR2_TOOLCHAIN_HAS_THREADS \
+               || !BR2_INSTALL_LIBSTDCPP || !BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_0
+
 endif
index ac39f1e5ce7208b46b285d7da14cff2d125c909d..f5b081f9724daaadb99214442825f9b694121589 100644 (file)
@@ -57,7 +57,6 @@ GST1_PLUGINS_BAD_CONF_OPTS += \
        --disable-gme \
        --disable-vdpau \
        --disable-schro \
-       --disable-zbar \
        --disable-spandsp \
        --disable-gtk3
 
@@ -719,6 +718,13 @@ else
 GST1_PLUGINS_BAD_CONF_OPTS += --disable-x265
 endif
 
+ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_ZBAR),y)
+GST1_PLUGINS_BAD_CONF_OPTS += --enable-zbar
+GST1_PLUGINS_BAD_DEPENDENCIES += zbar
+else
+GST1_PLUGINS_BAD_CONF_OPTS += --disable-zbar
+endif
+
 # Add GPL license if GPL licensed plugins enabled.
 ifeq ($(GST1_PLUGINS_BAD_HAS_GPL_LICENSE),y)
 GST1_PLUGINS_BAD_LICENSE := $(GST1_PLUGINS_BAD_LICENSE), GPL-2.0+