package/mpv: add optional support for OpenGL DRM EGL Backend
authorBernd Kuhls <bernd.kuhls@t-online.de>
Fri, 18 Jun 2021 19:22:36 +0000 (21:22 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 18 Jul 2021 21:33:03 +0000 (23:33 +0200)
Reference: https://github.com/mpv-player/mpv/blob/master/wscript#L571

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/mpv/mpv.mk

index 877b84f63ae450d668a20097efad860fcd8655ac..4292abb876d12d904c381dfe8cf4c66758a16fb8 100644 (file)
@@ -50,8 +50,13 @@ endif
 ifeq ($(BR2_PACKAGE_MESA3D_OPENGL_EGL),y)
 MPV_CONF_OPTS += --enable-gbm
 MPV_DEPENDENCIES += mesa3d
+ifeq ($(BR2_PACKAGE_LIBDRM),y)
+MPV_CONF_OPTS += --enable-egl-drm
+else
+MPV_CONF_OPTS += --disable-egl-drm
+endif
 else
-MPV_CONF_OPTS += --disable-gbm
+MPV_CONF_OPTS += --disable-gbm --disable-egl-drm
 endif
 
 # jack support