package/botan: add optional dependency to boost
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sat, 18 Aug 2018 23:30:50 +0000 (01:30 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 20 Aug 2018 21:32:50 +0000 (23:32 +0200)
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/botan/botan.mk

index 21a66adff1c6082e742af024f1efbb1d74684a8b..e25bf5b52f29e4db67e37c9a6d649d249d8e308e 100644 (file)
@@ -40,6 +40,11 @@ else
 BOTAN_CONF_OPTS += --without-stack-protector
 endif
 
+ifeq ($(BR2_PACKAGE_BOOST),y)
+BOTAN_DEPENDENCIES += boost
+BOTAN_CONF_OPTS += --with-boost
+endif
+
 ifeq ($(BR2_PACKAGE_BZIP2),y)
 BOTAN_DEPENDENCIES += bzip2
 BOTAN_CONF_OPTS += --with-bzip2