package/zic: bump version to 2016j
authorMartin Bark <martin@barkynet.com>
Sat, 3 Dec 2016 14:36:26 +0000 (14:36 +0000)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 4 Dec 2016 15:30:12 +0000 (16:30 +0100)
Signed-off-by: Martin Bark <martin@barkynet.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/zic/0001-remove-dependency-check-on-version-file.patch [new file with mode: 0644]
package/zic/zic.hash
package/zic/zic.mk

diff --git a/package/zic/0001-remove-dependency-check-on-version-file.patch b/package/zic/0001-remove-dependency-check-on-version-file.patch
new file mode 100644 (file)
index 0000000..f4b2590
--- /dev/null
@@ -0,0 +1,32 @@
+From 4ad8932f93c490d15586b1def3863e9580e6eceb Mon Sep 17 00:00:00 2001
+From: Martin Bark <martin@barkynet.com>
+Date: Sat, 3 Dec 2016 13:51:50 +0000
+Subject: [PATCH] remove dependency check on version file
+
+$(VERSION_DEPS) includes dependencies from tzdata meaning applications
+such as zic can't build from tzcode on their own.  Remove the dependency
+to $(VERSION_DEPS) since it is not necessary to check for version updates
+in released code.  This solves building zic from tzcode without needing
+tzdata.
+
+Signed-off-by: Martin Bark <martin@barkynet.com>
+---
+ Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index 1b714a8..00d2c09 100644
+--- a/Makefile
++++ b/Makefile
+@@ -437,7 +437,7 @@ INSTALL:   ALL install date.1
+               cp date $(DESTDIR)$(BINDIR)/.
+               cp -f date.1 $(DESTDIR)$(MANDIR)/man1/.
+-version:      $(VERSION_DEPS)
++version:
+               { (type git) >/dev/null 2>&1 && \
+                 V=`git describe --match '[0-9][0-9][0-9][0-9][a-z]*' \
+                               --abbrev=7 --dirty` || \
+-- 
+2.7.4
+
index 360575ac2fccebf5d41c9ee8017fc9bf30249493..6fe27bd2fc79e05d107a391230dde5446fbe8eed 100644 (file)
@@ -1,2 +1,2 @@
-# From http://mm.icann.org/pipermail/tz-announce/2016-July/000040.html
-sha512 97d084f4b0a688fef097dca256083ca9948393848d77c8ee637bdd26f859150cce7d2b26fc1165a3b44b28cc1c9075e10192332261ed68990b4b21a85438b023        tzcode2016f.tar.gz
+# From http://mm.icann.org/pipermail/tz-announce/2016-November/000044.html
+sha512 cac19dded22ff80cd784641ac239358c28cce535ac1eb60b52b7e51c6e9e5fe5f795ea0252daf32c949dddb9c5b24d7e4456d7869aa2725d49c5af58b564822a        tzcode2016j.tar.gz
index 8a0c8dccd5f3d98891a36ab2c1f850a4bc581ca8..ed7b04eb94fc1dceaeaab96fce5b1782fce563cf 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-ZIC_VERSION = 2016f
+ZIC_VERSION = 2016j
 ZIC_SOURCE = tzcode$(ZIC_VERSION).tar.gz
 ZIC_SITE = http://www.iana.org/time-zones/repository/releases
 ZIC_STRIP_COMPONENTS = 0