ruby: don't try to use gmp on the host
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 6 Sep 2014 13:59:26 +0000 (15:59 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 6 Sep 2014 20:12:10 +0000 (22:12 +0200)
When building host-ruby, if gmp seems to be available (for example
when host-gmp is built as a dependency of building the toolchain),
Ruby tries to use it. Unfortunately, it fails to use it because there
is no static version of host-gmp that is built and installed.

Since we anyway don't care much about gmp support in host-ruby, simply
disable it.

This issue was introduced since the bump to Ruby 2.1.0, and this
commit fixes:

  http://autobuild.buildroot.org/results/e19/e197f20bd5ec4aae6d8692d67df4f539a9df33e2/

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/ruby/ruby.mk

index 297e9024f10ae2a2a043f467811e5f5fc6f12dbe..384cc88d55dc1fce505abeca220e05bf6e645cc2 100644 (file)
@@ -14,7 +14,8 @@ RUBY_MAKE_ENV = $(TARGET_MAKE_ENV)
 RUBY_MAKE = $(MAKE1)
 RUBY_CONF_OPT = --disable-install-doc --disable-rpath
 HOST_RUBY_CONF_OPT = --disable-install-doc \
-       --with-out-ext=curses,openssl,readline
+       --with-out-ext=curses,openssl,readline \
+       --without-gmp
 RUBY_LICENSE = Ruby or BSD-2c, BSD-3c, others
 RUBY_LICENSE_FILES = LEGAL COPYING BSDL