package/open62541: force Release build
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Thu, 28 Jan 2021 19:46:19 +0000 (20:46 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 29 Jan 2021 08:33:53 +0000 (09:33 +0100)
Force Release build to remove -Werror and avoid the following build
failure:

/home/giuliobenetti/autobuild/run/instance-3/output-1/build/open62541-1.0/arch/network_tcp.c: At top level:
cc1: error: unrecognized command line option '-Wno-static-in-inline' [-Werror]
cc1: all warnings being treated as errors

Fixes:
 - http://autobuild.buildroot.org/results/24b429ce0ae2b33e72bb6a0f523c3906e539a4fd

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/open62541/open62541.mk

index 71c14f78ba627ff274fd1713bcd43a8335062833..5a9f27562a75a9be6dc0c8afb5f2a9b5c1943cba 100644 (file)
@@ -13,9 +13,11 @@ OPEN62541_INSTALL_STAGING = YES
 OPEN62541_LICENSE = MPL-2.0
 OPEN62541_LICENSE_FILES = LICENSE
 
+# Force Release build to remove -Werror.
 # Don't use git describe to get the version number.
 # Disable hardening options to let Buildroot handle it.
 OPEN62541_CONF_OPTS = \
+       -DCMAKE_BUILD_TYPE=Release \
        -DGIT_EXECUTABLE=NO \
        -DOPEN62541_VERSION=$(OPEN62541_VERSION) \
        -DUA_ENABLE_HARDENING=OFF