package/perl-crypt-openssl-rsa: new package
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 19 Apr 2015 10:17:18 +0000 (12:17 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 19 Apr 2015 11:43:45 +0000 (13:43 +0200)
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/perl-crypt-openssl-rsa/Config.in [new file with mode: 0644]
package/perl-crypt-openssl-rsa/perl-crypt-openssl-rsa.hash [new file with mode: 0644]
package/perl-crypt-openssl-rsa/perl-crypt-openssl-rsa.mk [new file with mode: 0644]

index 30585a6a15c18b198aef15331dc9945f77c8c325..8e04222eb729c3c57f1e3bf492d3ff3263516b4d 100644 (file)
@@ -503,6 +503,7 @@ endif
 if BR2_PACKAGE_PERL
 menu "Perl libraries/modules"
        source "package/perl-crypt-openssl-random/Config.in"
+       source "package/perl-crypt-openssl-rsa/Config.in"
        source "package/perl-datetime-tiny/Config.in"
        source "package/perl-digest-hmac/Config.in"
        source "package/perl-digest-sha1/Config.in"
diff --git a/package/perl-crypt-openssl-rsa/Config.in b/package/perl-crypt-openssl-rsa/Config.in
new file mode 100644 (file)
index 0000000..1fa1fd9
--- /dev/null
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_PERL_CRYPT_OPENSSL_RSA
+       bool "perl-crypt-openssl-rsa"
+       depends on !BR2_STATIC_LIBS
+       select BR2_PACKAGE_PERL_CRYPT_OPENSSL_RANDOM
+       help
+         RSA encoding and decoding, using the openSSL libraries
+
+         https://metacpan.org/release/Crypt-OpenSSL-RSA
+
+comment "perl-crypt-openssl-rsa needs a toolchain w/ dynamic library"
+       depends on BR2_STATIC_LIBS
diff --git a/package/perl-crypt-openssl-rsa/perl-crypt-openssl-rsa.hash b/package/perl-crypt-openssl-rsa/perl-crypt-openssl-rsa.hash
new file mode 100644 (file)
index 0000000..6e060ce
--- /dev/null
@@ -0,0 +1,3 @@
+# retrieved by scancpan from http://cpan.metacpan.org/
+md5    86217a5036fc63779c30420b5fd84129 Crypt-OpenSSL-RSA-0.28.tar.gz
+sha256 5357f977464bb3a8184cf2d3341851a10d5515b4b2b0dfb88bf78995c0ded7be Crypt-OpenSSL-RSA-0.28.tar.gz
diff --git a/package/perl-crypt-openssl-rsa/perl-crypt-openssl-rsa.mk b/package/perl-crypt-openssl-rsa/perl-crypt-openssl-rsa.mk
new file mode 100644 (file)
index 0000000..30d7303
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# perl-crypt-openssl-rsa
+#
+################################################################################
+
+PERL_CRYPT_OPENSSL_RSA_VERSION = 0.28
+PERL_CRYPT_OPENSSL_RSA_SOURCE = Crypt-OpenSSL-RSA-$(PERL_CRYPT_OPENSSL_RSA_VERSION).tar.gz
+PERL_CRYPT_OPENSSL_RSA_SITE = $(BR2_CPAN_MIRROR)/authors/id/P/PE/PERLER
+PERL_CRYPT_OPENSSL_RSA_DEPENDENCIES = perl perl-crypt-openssl-random
+PERL_CRYPT_OPENSSL_RSA_LICENSE = Artistic or GPLv1+
+PERL_CRYPT_OPENSSL_RSA_LICENSE_FILES = LICENSE
+
+$(eval $(perl-package))