mpv: va-api requires egl-drm, wayland and/or x11
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Thu, 28 Apr 2016 14:33:07 +0000 (11:33 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 28 Apr 2016 18:35:39 +0000 (20:35 +0200)
The VA-API acceleration requires one or more of the egl-drm, wayland
and/or x11 backends.
Since the egl-drm backend means LIBGL (X11) + EGL + DRM we'll handle it
later once the mesa3d libgl hidden knob is applied.
So for now we'll support wayland and x11 until that happens. Fixes:
http://autobuild.buildroot.net/results/4b9/4b98d0c2c0617715e77fb47b3d97037c6b7562ec/

[Peter: pass --disable-vaapi if libva isn't enabled,
 invert wayland/X11 test as suggested by Thomas]
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/mpv/mpv.mk

index 605e8912ffe328424107d62337641e32d2c1c0a7..3c6e3922b6f2794ce33c2af205bbdabf8161ce03 100644 (file)
@@ -177,12 +177,18 @@ MPV_CONF_OPTS += --disable-sdl1 --disable-sdl2
 endif
 
 # va-api support
+# This requires one or more of the egl-drm, wayland, x11 backends
+# For now we support wayland and x11
 ifeq ($(BR2_PACKAGE_LIBVA),y)
+ifneq ($(BR2_PACKAGE_WAYLAND)$(BR2_PACKAGE_XLIB_LIBX11),)
 MPV_CONF_OPTS += --enable-vaapi
 MPV_DEPENDENCIES += libva
 else
 MPV_CONF_OPTS += --disable-vaapi
 endif
+else
+MPV_CONF_OPTS += --disable-vaapi
+endif
 
 # wayland support
 ifeq ($(BR2_PACKAGE_WAYLAND),y)