package/gettext-tiny: take GNU gettext from our own directory
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 31 Mar 2019 13:23:45 +0000 (15:23 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 31 Mar 2019 13:23:45 +0000 (15:23 +0200)
Even though gettext-tiny re-uses the gettext-gnu source code, it makes
a separate download in the gettext-tiny download folder, so use this
one, and not the one from the gettext-gnu download folder, which may
not exist.

Fixes:

  http://autobuild.buildroot.net/results/4e289f30bc6e58ad81611e8e04779134dcbe1241/

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/gettext-tiny/gettext-tiny.mk

index 9efd798451be28958e0faaaeff9b47b24f95c509..a555fbef507f1e133f353d7940dac2d0dc0b6d12 100644 (file)
@@ -35,7 +35,7 @@ HOST_GETTEXT_TINY_EXTRA_DOWNLOADS = $(GETTEXT_GNU_SITE)/$(GETTEXT_GNU_SOURCE)
 define HOST_GETTEXT_TINY_EXTRACT_GNU_GETTEXT
        mkdir -p $(@D)/gettext-gnu
        $(call suitable-extractor,$(GETTEXT_GNU_SOURCE)) \
-               $(GETTEXT_GNU_DL_DIR)/$(GETTEXT_GNU_SOURCE) | \
+               $(GETTEXT_TINY_DL_DIR)/$(GETTEXT_GNU_SOURCE) | \
                $(TAR) --strip-components=1 -C $(@D)/gettext-gnu $(TAR_OPTIONS) -
 endef
 HOST_GETTEXT_TINY_POST_EXTRACT_HOOKS += HOST_GETTEXT_TINY_EXTRACT_GNU_GETTEXT