package/libtorrent-rasterbar: new package
authorPhilipp Richter <richterphilipp.pops@gmail.com>
Fri, 23 Nov 2018 18:14:25 +0000 (19:14 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 1 Dec 2018 22:20:11 +0000 (23:20 +0100)
libtorrent is a feature complete C++ bittorrent implementation
focusing on efficiency and scalability.

https://www.libtorrent.org/

Signed-off-by: Philipp Richter <richterphilipp.pops@gmail.com>
[Thomas: license is BSD-3c, not BSD-2c]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/libtorrent-rasterbar/Config.in [new file with mode: 0644]
package/libtorrent-rasterbar/libtorrent-rasterbar.hash [new file with mode: 0644]
package/libtorrent-rasterbar/libtorrent-rasterbar.mk [new file with mode: 0644]

index 7d43b3ccb248b05e806a4c8c79a0cee5450026c1..ad80d365dd75029df1df710b89dc2de9005da510 100644 (file)
@@ -1714,6 +1714,9 @@ F:        package/psplash/
 F:     package/sispmctl/
 F:     package/zsh/
 
+N:     Philipp Richter <richterphilipp.pops@gmail.com>
+F:     package/libtorrent-rasterbar/
+
 N:     Philippe Proulx <eeppeliteloop@gmail.com>
 F:     package/lttng-babeltrace/
 F:     package/lttng-libust/
index d02f9eadbbf18c5101b3786303caf3a7e6c6978d..0339ec77d787fa7eb07295cc76d0cee59f06b156 100644 (file)
@@ -1557,6 +1557,7 @@ menu "Networking"
        source "package/libstrophe/Config.in"
        source "package/libtirpc/Config.in"
        source "package/libtorrent/Config.in"
+       source "package/libtorrent-rasterbar/Config.in"
        source "package/libupnp/Config.in"
        source "package/libupnp18/Config.in"
        source "package/libupnpp/Config.in"
diff --git a/package/libtorrent-rasterbar/Config.in b/package/libtorrent-rasterbar/Config.in
new file mode 100644 (file)
index 0000000..aa986f2
--- /dev/null
@@ -0,0 +1,21 @@
+comment "libtorrent-rasterbar needs a toolchain w/ C++, threads, wchar, gcc >= 4.8"
+       depends on !BR2_INSTALL_LIBSTDCPP || !BR2_TOOLCHAIN_HAS_THREADS || !BR2_USE_WCHAR || \
+               !BR2_HOST_GCC_AT_LEAST_4_8 || !BR2_TOOLCHAIN_GCC_AT_LEAST_4_8
+
+config BR2_PACKAGE_LIBTORRENT_RASTERBAR
+       bool "libtorrent-rasterbar"
+       depends on BR2_INSTALL_LIBSTDCPP # boost
+       depends on BR2_HOST_GCC_AT_LEAST_4_8
+       depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_8
+       depends on BR2_TOOLCHAIN_HAS_THREADS # boost
+       depends on BR2_USE_WCHAR # boost
+       select BR2_PACKAGE_BOOST
+       select BR2_PACKAGE_BOOST_CHRONO
+       select BR2_PACKAGE_BOOST_SYSTEM
+       select BR2_PACKAGE_BOOST_RANDOM
+       select BR2_PACKAGE_OPENSSL
+       help
+         libtorrent is a feature complete C++ bittorrent implementation
+         focusing on efficiency and scalability.
+
+         https://www.libtorrent.org/
diff --git a/package/libtorrent-rasterbar/libtorrent-rasterbar.hash b/package/libtorrent-rasterbar/libtorrent-rasterbar.hash
new file mode 100644 (file)
index 0000000..e38c0f4
--- /dev/null
@@ -0,0 +1,3 @@
+# Locally calculated
+sha256 7c23deba7fa279825642307587609d51c9935ac7606e0ef2f2d0ba10728b5847 libtorrent-rasterbar-1.1.11.tar.gz
+sha256 f3a5dd1558cce616b12edad521427ec8976ce2bb0af33f7f359cfa648bf55ad8 COPYING
diff --git a/package/libtorrent-rasterbar/libtorrent-rasterbar.mk b/package/libtorrent-rasterbar/libtorrent-rasterbar.mk
new file mode 100644 (file)
index 0000000..24bd011
--- /dev/null
@@ -0,0 +1,25 @@
+################################################################################
+#
+# libtorrent-rasterbar
+#
+################################################################################
+
+LIBTORRENT_RASTERBAR_VERSION = 1.1.11
+LIBTORRENT_RASTERBAR_SITE = https://github.com/arvidn/libtorrent/releases/download/libtorrent_$(subst .,_,$(LIBTORRENT_RASTERBAR_VERSION))
+LIBTORRENT_RASTERBAR_LICENSE = BSD-3-Clause
+LIBTORRENT_RASTERBAR_LICENSE_FILES = COPYING
+LIBTORRENT_RASTERBAR_DEPENDENCIES = host-pkgconf boost openssl
+LIBTORRENT_RASTERBAR_INSTALL_STAGING = YES
+LIBTORRENT_RASTERBAR_CONF_OPTS = \
+       --with-boost-libdir=$(STAGING_DIR)/usr/lib \
+       --disable-invariant-checks
+LIBTORRENT_RASTERBAR_CONF_ENV += CXXFLAGS="$(TARGET_CXXFLAGS) -std=c++11"
+
+ifeq ($(BR2_ENABLE_LOCALE)$(BR2_PACKAGE_LIBICONV),y)
+LIBTORRENT_RASTERBAR_DEPENDENCIES += $(if $(BR2_PACKAGE_LIBICONV),libiconv)
+LIBTORRENT_RASTERBAR_CONF_OPTS += --with-libiconv
+else
+LIBTORRENT_RASTERBAR_CONF_OPTS += --without-libiconv
+endif
+
+$(eval $(autotools-package))