uboot-tools: force host CFLAGS
authorBaruch Siach <baruch@tkos.co.il>
Fri, 10 Aug 2018 05:37:21 +0000 (08:37 +0300)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 10 Aug 2018 08:34:11 +0000 (10:34 +0200)
U-Boot now adds -std=gnu11 when building its build utilities, like
fixdep. This option is only supported since gcc version 4.7.

  https://gcc.gnu.org/gcc-4.7/changes.html

Force usage of Buildroot HOST_CFLAGS, like we do already for
host-uboot-tools, to avoid the -std=gnu11 option.

Fixes:
http://autobuild.buildroot.net/results/ea0/ea09b614a3c10d494939d9551c0c3bfca4626ece/
http://autobuild.buildroot.net/results/f8e/f8efd9af4d86c51fe4f5afe44db9abf9adc5718f/
http://autobuild.buildroot.net/results/c0a/c0ab35c3cb46f84863fe20c0ee92ecc2379578b6/

Cc: Matt Weber <matthew.weber@rockwellcollins.com>
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/uboot-tools/uboot-tools.mk

index f5027d2da390ab3fd7f1b02bf78ccd854fa70105..5ac7b1c29399f8407bf5a7c7e7bc751dd4c13c70 100644 (file)
@@ -19,6 +19,7 @@ endef
 UBOOT_TOOLS_MAKE_OPTS = CROSS_COMPILE="$(TARGET_CROSS)" \
        CFLAGS="$(TARGET_CFLAGS)" \
        LDFLAGS="$(TARGET_LDFLAGS)" \
+       HOSTCFLAGS="$(HOST_CFLAGS)" \
        STRIP=$(TARGET_STRIP)
 
 ifeq ($(BR2_PACKAGE_UBOOT_TOOLS_FIT_SUPPORT),y)