package/qprint: new package
authorAlejandro González <alejandro.gonzalez.correo@gmail.com>
Sun, 20 Sep 2020 21:36:36 +0000 (23:36 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 22 Sep 2020 19:59:02 +0000 (21:59 +0200)
qprint is a small utility that handles encoding and decoding arbitrary
binary data in the Quoted-Printable format, which was introduced along
MIME.

As stated in the package description, although MUAs nowadays usually
take care of doing this encoding themselves, there are some use cases
where doing it manually is needed, and providing a command-line program
to do it is amenable to shell scripts.

Signed-off-by: Alejandro González <alejandro.gonzalez.correo@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/qprint/Config.in [new file with mode: 0644]
package/qprint/qprint.hash [new file with mode: 0644]
package/qprint/qprint.mk [new file with mode: 0644]

index 057592b8e58a9a0113f88a3e7b2c09080e4bba88..e6f2695e860645d4c22bf94b7f1a2c6ec67cb6e1 100644 (file)
@@ -119,6 +119,7 @@ F:  package/bird/
 F:     package/glorytun/
 
 N:     Alejandro González <alejandro.gonzalez.correo@gmail.com>
+F:     package/qprint/
 F:     package/watchdog/
 
 N:     Aleksander Morgado <aleksander@aleksander.es>
index c85a3c6bd3843d88670e4f0f03015ed86f37578d..956ac6f7b08a8486a9f61106800c6d5f16e2a0ed 100644 (file)
@@ -2350,6 +2350,7 @@ comment "Utilities"
        source "package/logsurfer/Config.in"
        source "package/pdmenu/Config.in"
        source "package/pinentry/Config.in"
+       source "package/qprint/Config.in"
        source "package/ranger/Config.in"
        source "package/rtty/Config.in"
        source "package/screen/Config.in"
diff --git a/package/qprint/Config.in b/package/qprint/Config.in
new file mode 100644 (file)
index 0000000..edfb92a
--- /dev/null
@@ -0,0 +1,18 @@
+config BR2_PACKAGE_QPRINT
+       bool "qprint"
+       help
+         qprint is a program that encodes and decodes binary data in
+         the Quoted-Printable encoding, defined as a part of the MIME
+         specification in RFC 1521. This encoding allows for efficient
+         transfer of mostly ASCII data over transports that are only
+         7-bit clean, like SMTP without 8BITMIME or BINARYMIME
+         extensions. It also allows the transfer of long lines of text
+         by wrapping them every 76 characters.
+
+         Usually, a sophisticated MUA will take care of automatically
+         choosing the best encodings for an e-mail. Nevertheless, this
+         utility may be useful when a MTA (e.g. msmtp) is used without
+         a MUA, or if using this encoding for other purposes is
+         desired.
+
+         https://www.fourmilab.ch/webtools/qprint/
diff --git a/package/qprint/qprint.hash b/package/qprint/qprint.hash
new file mode 100644 (file)
index 0000000..0412cf8
--- /dev/null
@@ -0,0 +1,3 @@
+# Locally computed
+sha256  ffa9ca1d51c871fb3b56a4bf0165418348cf080f01ff7e59cd04511b9665019c  qprint-1.1.tar.gz
+sha256  3bd4089942977a357fed0d3c84b6ea877000c20c7c344c2feabf4b10db9f7495  COPYING
diff --git a/package/qprint/qprint.mk b/package/qprint/qprint.mk
new file mode 100644 (file)
index 0000000..e34fba5
--- /dev/null
@@ -0,0 +1,13 @@
+################################################################################
+#
+# qprint
+#
+################################################################################
+
+QPRINT_VERSION = 1.1
+QPRINT_SITE = https://www.fourmilab.ch/webtools/qprint
+QPRINT_INSTALL_TARGET_OPTS = DESTDIR=$(TARGET_DIR) install-bin
+QPRINT_LICENSE = Public Domain
+QPRINT_LICENSE_FILES = COPYING
+
+$(eval $(autotools-package))