qt: remove no longer needed 'x86x86fix' workaround
authorMichael Roth <mroth@nessie.de>
Wed, 7 Oct 2009 09:20:31 +0000 (11:20 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 9 Oct 2009 12:40:37 +0000 (14:40 +0200)
Tested with 4.5.2.

Signed-off-by: Michael Roth <mroth@nessie.de>
Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/qt/qt.mk

index 77e7f1a3bbf5b80297551213f440d20061a64daf..6fe122cdf3c62006e4e515370dab4dc415d8af41 100644 (file)
 # (cd /usr/include; sudo ln -s dbus-1.0/dbus dbus)
 # to fix
 
-# BUG: There is a workaround below (search for x86x86fix) for
-# x86 crosscompiling under linux x86. Please remove it when the workaround
-# is no longer necessary.
-
 QT_VERSION:=4.5.2
 QT_CAT:=$(BZCAT)
 
@@ -329,17 +325,6 @@ endif
 QT_CONFIGURE:=$(call qstrip,$(QT_CONFIGURE))
 BR2_PACKAGE_QT_EMB_PLATFORM:=$(call qstrip,$(BR2_PACKAGE_QT_EMB_PLATFORM))
 
-# x86x86fix
-# Workaround Qt Embedded bug when crosscompiling for x86 under x86 with linux
-# host. It's unclear if this would happen on other hosts.
-ifneq ($(findstring pc-linux,$(BR2_GNU_BUILD_SUFFIX)),)
-ifeq ($(BR2_PACKAGE_QT_EMB_PLATFORM),x86)
-QT_CONFIGURE+= -platform linux-g++
-QT_CONFIGURE:=$(call qstrip,$(QT_CONFIGURE))
-endif
-endif
-# End of workaround.
-
 # Figure out what libs to install in the target
 QT_LIBS=#empty
 ifeq ($(BR2_PACKAGE_QT_GUI_MODULE),y)