x265: disable parallel build
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Mon, 1 Oct 2018 20:57:39 +0000 (22:57 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 3 Oct 2018 07:32:06 +0000 (09:32 +0200)
It seems package has a parallel build issue on ARM cortex A8 or A9 since
at least version 2.5:

[ 94%] Linking CXX shared library libx265.so
ipfilter8.S.o: file not recognized: File truncated
collect2: error: ld returned 1 exit status
CMakeFiles/x265-shared.dir/build.make:221: recipe for target 'libx265.so.160' failed

Fixes:
 - http://autobuild.buildroot.org/results/f6ea88324a8f9ac8ee780ddd71ec61f922e20210
 - http://autobuild.buildroot.org/results/3bd91a5694936650ce936a408ddd50338f65f8b0

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/x265/x265.mk

index 0ad27ee006c98cdc3b6317e960364a03e0e184e7..fe317d09d057425a26381430a7c143c1a175e7db 100644 (file)
@@ -11,6 +11,7 @@ X265_LICENSE = GPL-2.0+
 X265_LICENSE_FILES = COPYING
 X265_SUBDIR = source
 X265_INSTALL_STAGING = YES
+X265_MAKE = $(MAKE1)
 
 ifeq ($(BR2_i386)$(BR2_x86_64),y)
 X265_DEPENDENCIES += host-nasm