coreutils: add optionals, use single binary
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Sat, 25 Oct 2014 02:06:45 +0000 (23:06 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 25 Oct 2014 08:44:00 +0000 (10:44 +0200)
Add proper support for optional libraries: acl, attr, gmp & libcap.

Also build the single binary as pointed out by Pádraig Brady for some
neat space savings.
Use the shebang (default) method since it allows us to move binaries
into other directories to suit our needs whereas for symlink that
wouldn't be so easy.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/coreutils/coreutils.mk

index 54c7892e51ca5efe49efb7133dfb9d31bef9db02..1a25a3ac7b6fff1ec6a3cde7b81175514644b12e 100644 (file)
@@ -20,6 +20,30 @@ ifeq ($(BR2_PACKAGE_BUSYBOX),y)
 COREUTILS_DEPENDENCIES = busybox
 endif
 
+ifeq ($(BR2_PACKAGE_ACL),y)
+COREUTILS_DEPENDENCIES += acl
+else
+COREUTILS_CONF_OPTS += --disable-acl
+endif
+
+ifeq ($(BR2_PACKAGE_ATTR),y)
+COREUTILS_DEPENDENCIES += attr
+else
+COREUTILS_CONF_OPTS += --disable-xattr
+endif
+
+ifeq ($(BR2_PACKAGE_GMP),y)
+COREUTILS_DEPENDENCIES += gmp
+else
+COREUTILS_CONF_OPTS += --without-gmp
+endif
+
+ifeq ($(BR2_PACKAGE_LIBCAP),y)
+COREUTILS_DEPENDENCIES += libcap
+else
+COREUTILS_CONF_OPTS += --disable-libcap
+endif
+
 COREUTILS_BIN_PROGS = cat chgrp chmod chown cp date dd df dir echo false \
        ln ls mkdir mknod mv pwd rm rmdir vdir sleep stty sync touch true \
        uname join
@@ -61,7 +85,7 @@ COREUTILS_CONF_ENV = ac_cv_c_restrict=no \
                utils_cv_localtime_cache=no \
                PERL=missing
 
-COREUTILS_CONF_OPTS = --disable-rpath
+COREUTILS_CONF_OPTS = --disable-rpath --enable-single-binary=shebangs
 
 define COREUTILS_POST_INSTALL
        # some things go in root rather than usr