package/avrdude: Switch to upstream
authorAlexander Sverdlin <alexander.sverdlin@gmail.com>
Mon, 22 Feb 2021 02:26:06 +0000 (03:26 +0100)
committerYann E. MORIN <yann.morin.1998@free.fr>
Mon, 8 Mar 2021 23:02:49 +0000 (00:02 +0100)
In the meanwhile "linuxspi" programmer was merged upstream, therefore
it's possible to switch to latest upstream tree instead of the old fork
without losing any functionality.

The fork we were using did auto-detection of kernel headers to detect
whether spidev.h was present or not, and thus whether to enable or
disable its linuxspi 'driver'. As spidev.h has been present since
linux-2.6.22, we can quite easily conclude that spidev support was
always enabled in the fork.

But upstream went a slightly different route, and added a configure
option (and they do no validity check).

So, to keep backward behaviour, we unconditionally enable it  now that
we switched back to use upstream.

Signed-off-by: Alexander Sverdlin <alexander.sverdlin@gmail.com>
[yann.morin.1998@free.fr:
  - clarify why we forcibly use --enable-linuxspi
  - fix the hash to adapt to the new svn tarball format (c043ecb20ce6)
]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/avrdude/avrdude.hash
package/avrdude/avrdude.mk

index 888668ae44d39a9eade955c41d2e92853b55aae6..c7b4bf85bcb1d86a04984abac2ebd189c23a4fe4 100644 (file)
@@ -1,3 +1,3 @@
 # Locally computed
-sha256  cfa97af7badc713c62306ab85d0e7a288b064bf72e698494f73cb16c5b2c659e  avrdude-f8893ccf0aceeff67c45f95ae4e86bc7fbe342aa.tar.gz
+sha256  a74532a61d07e43fc598ade4202e9a8c8697bce3e6031c5be6f51da651595f99  avrdude-r1450-br1.tar.gz
 sha256  201babc7da198873304a77a30dbfc7ca449c9bba52df2dffa4cca0009dbdfcb2  avrdude/COPYING
index ae378dfbace83418874e4db530ef97036ad73caf..b6754684e143ad39534fc45563ad7acb33f4b9c2 100644 (file)
@@ -4,15 +4,16 @@
 #
 ################################################################################
 
-AVRDUDE_VERSION = f8893ccf0aceeff67c45f95ae4e86bc7fbe342aa
-AVRDUDE_SITE = $(call github,kcuzner,avrdude,$(AVRDUDE_VERSION))
+AVRDUDE_VERSION = r1450
+AVRDUDE_SITE_METHOD = svn
+AVRDUDE_SITE = http://svn.savannah.nongnu.org/svn/avrdude/trunk
 AVRDUDE_LICENSE = GPL-2.0+
 AVRDUDE_LICENSE_FILES = avrdude/COPYING
 AVRDUDE_SUBDIR = avrdude
-# Sources coming from git, without generated configure and Makefile.in
+# Sources coming from svn, without generated configure and Makefile.in
 # files.
 AVRDUDE_AUTORECONF = YES
-AVRDUDE_CONF_OPTS = --enable-linuxgpio
+AVRDUDE_CONF_OPTS = --enable-linuxgpio --enable-linuxspi
 AVRDUDE_DEPENDENCIES = elfutils libusb libusb-compat ncurses \
        host-flex host-bison