kvm-unit-tests: bump version to fix build issue
authorCyril Bur <cyrilbur@gmail.com>
Mon, 20 Nov 2017 05:48:40 +0000 (16:48 +1100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 20 Nov 2017 21:11:47 +0000 (22:11 +0100)
Since binutils commit 1a9ccd70f9a7 ("Fix the linker so that it will not
silently generate ELF binaries with invalid program headers. Fix readelf
to report such invalid binaries.") the behaviour has changed and
binutils tries to create a program header segment for which there is no
space. Thanks to Nicholas Piggin and his patch to Linux:
https://git.kernel.org/pub/scm/linux/kernel/git/powerpc/linux.git/commit/?h=next&id=ff45000fcb56b5b0f

Cedric fixed this in kvm-unit-tests commit 95062c20790d ("powerpc: add
-n to LDFLAGS") so bump to that version.

Since the patch 0001-remove-werror.patch needs to be adjusted, we take
this opportunity to reformat is as a Git patch.

Fixes:

  http://autobuild.buildroot.net/results/80825b492abf61313637b109d6a0944b38d5f739

Signed-off-by: Cyril Bur <cyrilbur@gmail.com>
[Thomas: add necessary hash change, refresh patch that was not
applying anymore.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/kvm-unit-tests/0001-Makefile-remove-Werror-to-avoid-build-failures.patch [new file with mode: 0644]
package/kvm-unit-tests/0001-remove-werror.patch [deleted file]
package/kvm-unit-tests/kvm-unit-tests.hash
package/kvm-unit-tests/kvm-unit-tests.mk

diff --git a/package/kvm-unit-tests/0001-Makefile-remove-Werror-to-avoid-build-failures.patch b/package/kvm-unit-tests/0001-Makefile-remove-Werror-to-avoid-build-failures.patch
new file mode 100644 (file)
index 0000000..b1ea092
--- /dev/null
@@ -0,0 +1,26 @@
+From 08e14a662b9e75daec29722e49150869952ba1b6 Mon Sep 17 00:00:00 2001
+From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+Date: Mon, 20 Nov 2017 22:09:39 +0100
+Subject: [PATCH] Makefile: remove -Werror to avoid build failures
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+---
+ Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index 16ce297..909498e 100644
+--- a/Makefile
++++ b/Makefile
+@@ -45,7 +45,7 @@ cc-option = $(shell if $(CC) $(1) -S -o /dev/null -xc /dev/null \
+               > /dev/null 2>&1; then echo "$(1)"; else echo "$(2)"; fi ;)
+ CFLAGS += -g
+-CFLAGS += $(autodepend-flags) -Wall -Werror
++CFLAGS += $(autodepend-flags) -Wall
+ frame-pointer-flag=-f$(if $(KEEP_FRAME_POINTER),no-,)omit-frame-pointer
+ fomit_frame_pointer := $(call cc-option, $(frame-pointer-flag), "")
+ fnostack_protector := $(call cc-option, -fno-stack-protector, "")
+-- 
+2.13.6
+
diff --git a/package/kvm-unit-tests/0001-remove-werror.patch b/package/kvm-unit-tests/0001-remove-werror.patch
deleted file mode 100644 (file)
index 058a640..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
-Remove -Werror to avoid build failures
-
-Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-
-Index: b/Makefile
-===================================================================
---- a/Makefile
-+++ b/Makefile
-@@ -45,7 +45,7 @@
-               > /dev/null 2>&1; then echo "$(1)"; else echo "$(2)"; fi ;)
- CFLAGS += -g
--CFLAGS += $(autodepend-flags) -Wall -Werror -Wno-frame-address
-+CFLAGS += $(autodepend-flags) -Wall -Wno-frame-address
- frame-pointer-flag=-f$(if $(KEEP_FRAME_POINTER),no-,)omit-frame-pointer
- fomit_frame_pointer := $(call cc-option, $(frame-pointer-flag), "")
- fnostack_protector := $(call cc-option, -fno-stack-protector, "")
index b83e57de502ed8de5ff5d9bcfd27894916280680..2a4cfe021aa4babc820f68c68fcfc5fa338c7e72 100644 (file)
@@ -1,2 +1,2 @@
 # Locally computed
-sha256 8cb85e5af51820dea8c250e1d4dac723de92c5cd8878354c6fa5c099975f3264  kvm-unit-tests-5731572b2ac23eb410732110b93425b5bb7f27dd.tar.gz
+sha256 ccb9ff17a2c7d6c7d50b4b71b87381181b45484187100ae5b1ac54d9d61e8666  kvm-unit-tests-95062c20790d82713bfa7475b61a4adef3f3645a.tar.gz
index 3a5d0fd12546ac6396ce1ae72575b56df486609c..c630ec6270b295519dda6a5066f469fe978899b0 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-KVM_UNIT_TESTS_VERSION = 5731572b2ac23eb410732110b93425b5bb7f27dd
+KVM_UNIT_TESTS_VERSION = 95062c20790d82713bfa7475b61a4adef3f3645a
 KVM_UNIT_TESTS_SITE = $(BR2_KERNEL_MIRROR)/scm/virt/kvm/kvm-unit-tests.git
 KVM_UNIT_TESTS_SITE_METHOD = git
 KVM_UNIT_TESTS_LICENSE = LGPL-2.0