python-serial: fix Python 2.7.x related compilation error
authorYegor Yefremov <yegorslists@googlemail.com>
Mon, 6 Jun 2016 11:30:11 +0000 (13:30 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 6 Jun 2016 19:42:54 +0000 (21:42 +0200)
aio.py is an experimental module, that is compatible with
Python 3 only, so remove it for Python 2 environment or it
will cause compilation errors.

Fixes:
http://autobuild.buildroot.org/results/f26/f26351da925d6ef3adea8053dc7fc24061554daf/

Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/python-serial/python-serial.mk

index 696e2079447ebe2471bb4a2abbeae660a20f3a4e..4b3ffadc1c581446a405702e11439eadf5c0582b 100644 (file)
@@ -11,4 +11,14 @@ PYTHON_SERIAL_LICENSE = Python Software Foundation License
 PYTHON_SERIAL_LICENSE_FILES = LICENSE.txt
 PYTHON_SERIAL_SETUP_TYPE = setuptools
 
+# aio.py is an experimental module, that is compatible only with
+# Python 3, so remove it for Python 2 environment or it will
+# cause compilation errors
+ifeq ($(BR2_PACKAGE_PYTHON),y)
+define PYTHON_SERIAL_REMOVE_AIO_PY
+       rm $(@D)/serial/aio.py
+endef
+PYTHON_SERIAL_POST_EXTRACT_HOOKS = PYTHON_SERIAL_REMOVE_AIO_PY
+endif
+
 $(eval $(python-package))