pcmanfm: replace dependency on X.org server by dependency on libX11
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 18 Dec 2012 23:13:23 +0000 (23:13 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 19 Dec 2012 13:52:18 +0000 (14:52 +0100)
There is no reason for a client program like pcmanfm to depend on the
X.org server. Instead, it should depend on the appropriate X
client libraries, in this case libX11.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/pcmanfm/Config.in
package/pcmanfm/pcmanfm.mk

index c8b4debff8a319751c1cad776077f6120a2fa565..484192b1b8ea5516798dcc801ffe07cc918715b7 100644 (file)
@@ -4,6 +4,7 @@ config BR2_PACKAGE_PCMANFM
        depends on BR2_USE_WCHAR # glib2
        select BR2_PACKAGE_GAMIN
        select BR2_PACKAGE_STARTUP_NOTIFICATION
+       select BR2_PACKAGE_XLIB_LIBX11
        depends on BR2_PACKAGE_LIBGTK2
        help
          An extremly fast and lightweight file manager which features
index 3b0b7278f1c2858d68ff50ec07f88bc62b1b6ba0..392e3ad79adaade30b8c4edb40a81b11c9a071e2 100644 (file)
@@ -7,7 +7,7 @@ PCMANFM_VERSION = 0.3.5.9
 PCMANFM_SOURCE = pcmanfm-$(PCMANFM_VERSION).tar.gz
 PCMANFM_SITE = http://downloads.sourceforge.net/project/pcmanfm/pcmanfm-legacy%20%28Old%200.5%20series%29/PCManFM%20$(PCMANFM_VERSION)
 PCMANFM_CONF_OPT = --disable-hal
-PCMANFM_DEPENDENCIES = host-pkgconf libgtk2 gamin startup-notification xserver_xorg-server
+PCMANFM_DEPENDENCIES = host-pkgconf libgtk2 gamin startup-notification xlib_libX11
 PCMANFM_AUTORECONF = YES
 
 $(eval $(autotools-package))