package/minetest: add hiredis optional dependency
authorRomain Naour <romain.naour@gmail.com>
Thu, 13 Jul 2017 12:40:49 +0000 (14:40 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 21 Oct 2017 15:19:32 +0000 (17:19 +0200)
Signed-off-by: Romain Naour <romain.naour@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/minetest/minetest.mk

index ba0bf240915229e94c0565b833be6ac273a4776d..583bb56342af356350069190eb4c9ce0820fd855 100644 (file)
@@ -17,7 +17,6 @@ MINETEST_CONF_OPTS = \
        -DENABLE_LUAJIT=ON \
        -DENABLE_CURSES=OFF \
        -DENABLE_LEVELDB=OFF \
-       -DENABLE_REDIS=OFF \
        -DENABLE_SPATIAL=OFF \
        -DAPPLY_LOCALE_BLACKLIST=OFF \
        -DENABLE_SYSTEM_GMP=ON \
@@ -50,6 +49,13 @@ else
 MINETEST_CONF_OPTS += -DENABLE_FREETYPE=OFF
 endif
 
+ifeq ($(BR2_PACKAGE_HIREDIS),y)
+MINETEST_DEPENDENCIES += hiredis
+MINETEST_CONF_OPTS += -DENABLE_REDIS=ON
+else
+MINETEST_CONF_OPTS += -DENABLE_REDIS=OFF
+endif
+
 ifeq ($(BR2_PACKAGE_LIBCURL),y)
 MINETEST_DEPENDENCIES += libcurl
 MINETEST_CONF_OPTS += -DENABLE_CURL=ON