fs/f2fs: add option to define list of cold file extensions
authorGrzegorz Blach <grzegorz@blach.pl>
Sat, 3 Nov 2018 14:17:02 +0000 (15:17 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 3 Nov 2018 14:17:02 +0000 (15:17 +0100)
Signed-off-by: Grzegorz Blach <grzegorz@blach.pl>
[Thomas: split from the initial patch from Grzegorz]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
fs/f2fs/Config.in
fs/f2fs/f2fs.mk

index e62bc652efa617777f46e6f07e943f3ca95ddd7a..ca838096d9e68d8ed6a870a85c919d3f938fd6e7 100644 (file)
@@ -18,4 +18,11 @@ config BR2_TARGET_ROOTFS_F2FS_SIZE
          Suffix with K, M, G or T for power-of-two kilo-, mega-, giga-
          or terabytes.
 
+config BR2_TARGET_ROOTFS_F2FS_COLD_FILES
+       string "extension list for cold files"
+       help
+         Specify a file extension list in order f2fs to treat them as
+         cold files. The default list includes most of multimedia
+         file extensions such as jpg, gif, mpeg, mkv, and so on.
+
 endif # BR2_TARGET_ROOTFS_F2FS
index c954386b0549965f18ca093df70597dbbc36f7d7..6025aad4bb9d484eb353f96c165f65619943f83c 100644 (file)
@@ -13,10 +13,12 @@ endif
 # variable is not qstrip-ed to preserve the integrity of the string value.
 F2FS_LABEL := $(subst ",,$(BR2_TARGET_ROOTFS_F2FS_LABEL))
 # ")
+F2FS_COLD_FILES = $(call qstrip,$(BR2_TARGET_ROOTFS_F2FS_COLD_FILES))
 
 F2FS_OPTS = \
        -f \
-       -l "$(F2FS_LABEL)"
+       -l "$(F2FS_LABEL)" \
+       $(if $(F2FS_COLD_FILES),-e "$(F2FS_COLD_FILES)")
 
 ROOTFS_F2FS_DEPENDENCIES = host-f2fs-tools