clean up & import packages by gtj
authorMike Frysinger <vapier@gentoo.org>
Tue, 18 Jan 2005 00:28:09 +0000 (00:28 -0000)
committerMike Frysinger <vapier@gentoo.org>
Tue, 18 Jan 2005 00:28:09 +0000 (00:28 -0000)
libpcap: http://bugs.uclibc.org/view.php?id=20
tcpdump: http://bugs.uclibc.org/view.php?id=21

package/Config.in
package/libpcap/Config.in [new file with mode: 0644]
package/libpcap/Makefile.in [new file with mode: 0644]
package/libpcap/libpcap.mk [new file with mode: 0644]
package/libpcap/libpcap.patch [new file with mode: 0644]
package/tcpdump/Config.in [new file with mode: 0644]
package/tcpdump/Makefile.in [new file with mode: 0644]
package/tcpdump/tcpdump.mk [new file with mode: 0644]

index eaf53a7eb22d8783e175cfb1ae3b0d2bca9087e8..96c2266d7a17eed6985a208680942ba62fd2f874 100644 (file)
@@ -58,6 +58,7 @@ source "package/less/Config.in"
 source "package/libfloat/Config.in"
 source "package/libglib12/Config.in"
 source "package/libmad/Config.in"
+source "package/libpcap/Config.in"
 source "package/libpng/Config.in"
 source "package/libtool/Config.in"
 source "package/links/Config.in"
@@ -97,6 +98,7 @@ source "package/sfdisk/Config.in"
 source "package/slang/Config.in"
 source "package/socat/Config.in"
 source "package/strace/Config.in"
+source "package/tcpdump/Config.in"
 source "package/tinylogin/Config.in"
 source "package/tinyx/Config.in"
 source "package/tn5250/Config.in"
diff --git a/package/libpcap/Config.in b/package/libpcap/Config.in
new file mode 100644 (file)
index 0000000..7aa6a5b
--- /dev/null
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_LIBPCAP
+       bool "libpcap"
+       default n
+       help
+         A system-independent library for user-level network packet capture.
+
+         http://www.tcpdump.org/
diff --git a/package/libpcap/Makefile.in b/package/libpcap/Makefile.in
new file mode 100644 (file)
index 0000000..f158d9d
--- /dev/null
@@ -0,0 +1,3 @@
+ifeq ($(strip $(BR2_PACKAGE_LIBPCAP)),y)
+TARGETS+=libpcap
+endif
diff --git a/package/libpcap/libpcap.mk b/package/libpcap/libpcap.mk
new file mode 100644 (file)
index 0000000..53ec7f0
--- /dev/null
@@ -0,0 +1,79 @@
+#############################################################
+#
+# libpcap 
+#
+#############################################################
+# Copyright (C) 2001-2003 by Erik Andersen <andersen@codepoet.org>
+# Copyright (C) 2002 by Tim Riker <Tim@Rikers.org>
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU Library General Public License as
+# published by the Free Software Foundation; either version 2 of the
+# License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# Library General Public License for more details.
+#
+# You should have received a copy of the GNU Library General Public
+# License along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
+# USA
+
+LIBPCAP_VER:=0.8.3
+LIBPCAP_DIR:=$(BUILD_DIR)/libpcap-$(LIBPCAP_VER)
+LIBPCAP_SITE:=http://www.tcpdump.org/release
+LIBPCAP_SOURCE:=libpcap-$(LIBPCAP_VER).tar.gz
+LIBPCAP_CAT:=zcat
+
+$(DL_DIR)/$(LIBPCAP_SOURCE):
+        $(WGET) -P $(DL_DIR) $(LIBPCAP_SITE)/$(LIBPCAP_SOURCE)
+
+libpcap-source: $(DL_DIR)/$(LIBPCAP_SOURCE)
+
+$(LIBPCAP_DIR)/.unpacked: $(DL_DIR)/$(LIBPCAP_SOURCE)
+       $(LIBPCAP_CAT) $(DL_DIR)/$(LIBPCAP_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
+       toolchain/patch-kernel.sh $(LIBPCAP_DIR) package/libpcap/ *.patch
+       touch $(LIBPCAP_DIR)/.unpacked
+
+$(LIBPCAP_DIR)/.configured: $(LIBPCAP_DIR)/.unpacked
+       ( \
+               cd $(LIBPCAP_DIR) ; \
+               ac_cv_linux_vers=$(BR2_DEFAULT_KERNEL_HEADERS) \
+               BUILD_CC=$(TARGET_CC) HOSTCC=$(HOSTCC) \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               ./configure \
+               --target=$(GNU_TARGET_NAME) \
+               --host=$(GNU_TARGET_NAME) \
+               --build=$(GNU_HOST_NAME) \
+               --with-build-cc=$(HOSTCC) \
+               --disable-yydebug \
+               --prefix=/usr \
+               --with-pcap=linux \
+       )
+       touch $(LIBPCAP_DIR)/.configured
+
+$(LIBPCAP_DIR)/libpcap.a: $(LIBPCAP_DIR)/.configured
+       $(MAKE) \
+               AR="$(TARGET_CROSS)ar" \
+               -C $(LIBPCAP_DIR)
+
+$(STAGING_DIR)/lib/libpcap.a: $(LIBPCAP_DIR)/libpcap.a
+       $(MAKE) \
+               -C $(LIBPCAP_DIR) \
+               prefix=$(STAGING_DIR) \
+               exec_prefix=$(STAGING_DIR) \
+               bindir=$(STAGING_DIR)/bin \
+               datadir=$(STAGING_DIR)/share \
+               install
+
+libpcap: uclibc zlib $(STAGING_DIR)/lib/libpcap.a
+
+libpcap-clean:
+       rm -f $(STAGING_DIR)/include/pcap*.h $(STAGING_DIR)/lib/libpcap.a
+       -$(MAKE) -C $(LIBPCAP_DIR) clean
+
+libpcap-dirclean:
+       rm -rf $(LIBPCAP_DIR)
diff --git a/package/libpcap/libpcap.patch b/package/libpcap/libpcap.patch
new file mode 100644 (file)
index 0000000..196ee34
--- /dev/null
@@ -0,0 +1,11 @@
+--- libpcap-0.8.3/Makefile.in.orig     2005-01-17 19:04:41.291056960 -0500
++++ libpcap-0.8.3/Makefile.in  2005-01-17 19:04:47.836061968 -0500
+@@ -100,7 +100,7 @@
+ libpcap.a: $(OBJ)
+       @rm -f $@
+-      ar rc $@ $(OBJ) $(LIBS)
++      $(AR) rc $@ $(OBJ) $(LIBS)
+       $(RANLIB) $@
+ scanner.c: $(srcdir)/scanner.l
diff --git a/package/tcpdump/Config.in b/package/tcpdump/Config.in
new file mode 100644 (file)
index 0000000..de17e4f
--- /dev/null
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_TCPDUMP
+       bool "tcpdump"
+       default n
+       help
+         A tool for network monitoring and data acquisition.
+
+         http://www.tcpdump.org/
diff --git a/package/tcpdump/Makefile.in b/package/tcpdump/Makefile.in
new file mode 100644 (file)
index 0000000..eb0a85c
--- /dev/null
@@ -0,0 +1,3 @@
+ifeq ($(strip $(BR2_PACKAGE_TCPDUMP)),y)
+TARGETS+=tcpdump
+endif
diff --git a/package/tcpdump/tcpdump.mk b/package/tcpdump/tcpdump.mk
new file mode 100644 (file)
index 0000000..13d9c44
--- /dev/null
@@ -0,0 +1,75 @@
+#############################################################
+#
+# tcpdump 
+#
+#############################################################
+# Copyright (C) 2001-2003 by Erik Andersen <andersen@codepoet.org>
+# Copyright (C) 2002 by Tim Riker <Tim@Rikers.org>
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU Library General Public License as
+# published by the Free Software Foundation; either version 2 of the
+# License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# Library General Public License for more details.
+#
+# You should have received a copy of the GNU Library General Public
+# License along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
+# USA
+
+TCPDUMP_VER:=3.8.3
+TCPDUMP_DIR:=$(BUILD_DIR)/tcpdump-$(TCPDUMP_VER)
+TCPDUMP_SITE:=http://www.tcpdump.org/release
+TCPDUMP_SOURCE:=tcpdump-$(TCPDUMP_VER).tar.gz
+TCPDUMP_CAT:=zcat
+
+$(DL_DIR)/$(TCPDUMP_SOURCE):
+        $(WGET) -P $(DL_DIR) $(TCPDUMP_SITE)/$(TCPDUMP_SOURCE)
+
+tcpdump-source: $(DL_DIR)/$(TCPDUMP_SOURCE)
+
+$(TCPDUMP_DIR)/.unpacked: $(DL_DIR)/$(TCPDUMP_SOURCE)
+       $(TCPDUMP_CAT) $(DL_DIR)/$(TCPDUMP_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
+       touch $(TCPDUMP_DIR)/.unpacked
+
+$(TCPDUMP_DIR)/.configured: $(TCPDUMP_DIR)/.unpacked
+       ( \
+               cd $(TCPDUMP_DIR) ; \
+               ac_cv_linux_vers=$(BR2_DEFAULT_KERNEL_HEADERS) \
+               BUILD_CC=$(TARGET_CC) HOSTCC=$(HOSTCC) \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               ./configure \
+               --target=$(GNU_TARGET_NAME) \
+               --host=$(GNU_TARGET_NAME) \
+               --build=$(GNU_HOST_NAME) \
+               --with-build-cc=$(HOSTCC) \
+               --prefix=$(STAGING_DIR) \
+               --libdir=$(STAGING_DIR)/lib \
+               --includedir=$(STAGING_DIR)/include \
+       )
+       $(SED) '/HAVE_PCAP_DEBUG/d' $(TCPDUMP_DIR)/config.h
+       touch $(TCPDUMP_DIR)/.configured
+
+$(TCPDUMP_DIR)/tcpdump: $(TCPDUMP_DIR)/.configured
+       $(MAKE) \
+               LDFLAGS="-L$(STAGING_DIR)/lib" \
+               LIBS="-lpcap" \
+               INCLS="-I. -I$(STAGING_DIR)/include" \
+               -C $(TCPDUMP_DIR)
+       
+$(TARGET_DIR)/sbin/tcpdump: $(TCPDUMP_DIR)/tcpdump
+       cp -af $< $@
+
+tcpdump: uclibc zlib libpcap $(TARGET_DIR)/sbin/tcpdump
+
+tcpdump-clean:
+       rm -f $(TARGET_DIR)/sbin/tcpdump
+       -$(MAKE) -C $(TCPDUMP_DIR) clean
+
+tcpdump-dirclean:
+       rm -rf $(TCPDUMP_DIR)