aiccu: don't link with librt
authorBaruch Siach <baruch@tkos.co.il>
Fri, 16 Jun 2017 03:32:53 +0000 (06:32 +0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 20 Jun 2017 20:13:15 +0000 (22:13 +0200)
Buildroot no longer supports toolchains with glibc older than 2.17, so there
is no need to link with librt for clock_* system calls.

Cc: Michael Rommel <rommel@layer-7.net>
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/aiccu/0003-clock-suite-functions-fix.patch [deleted file]
package/aiccu/0003-if-ether-header.patch [new file with mode: 0644]
package/aiccu/0004-if-ether-header.patch [deleted file]

diff --git a/package/aiccu/0003-clock-suite-functions-fix.patch b/package/aiccu/0003-clock-suite-functions-fix.patch
deleted file mode 100644 (file)
index 365e72a..0000000
+++ /dev/null
@@ -1,18 +0,0 @@
-aiccu: fix undefined reference to clock_* functions
-
-Since glibc 2.17 the clock_* suite functions are available directly in 
-the main C library. For previous versions we still need -lrt to link.
-
-Signed-off-by: Vicente Olivert Riera <vincent.riera@imgtec.com>
-
---- aiccu/unix-console/Makefile.orig   2014-01-14 10:17:20.204602513 +0000
-+++ aiccu/unix-console/Makefile        2014-01-14 10:17:31.435777359 +0000
-@@ -42,7 +42,7 @@ CFLAGS       += -D AICCU_CONSOLE
- # Currently defaultly builds only on Linux, but other platforms might easily also support it
- ifeq ($(shell uname | grep -c "Linux"),1)
- CFLAGS        += -D AICCU_GNUTLS
--LDFLAGS += -lgnutls
-+LDFLAGS += -lgnutls -lrt
- endif
- # Linux
diff --git a/package/aiccu/0003-if-ether-header.patch b/package/aiccu/0003-if-ether-header.patch
new file mode 100644 (file)
index 0000000..48e8ceb
--- /dev/null
@@ -0,0 +1,23 @@
+musl does not allow using <netinet/*> together with <linux/*> headers.
+Since there are both netinet/if_ether.h and linux/if_ether.h providing
+the same definitions, use linux/if_ether.h whenever other linux/*
+headers are included.
+
+Signed-off-by: Alex Suykov <alex.suykov@gmail.com>
+
+--- aiccu/common/common.h
++++ aiccu/common/common.h
+@@ -91,11 +91,12 @@
+       #include <sys/select.h>
+       #include <net/if.h>
+-      #include <netinet/if_ether.h>
+ #ifdef linux
+       #include <netpacket/packet.h>
++      #include <linux/if_ether.h>
+       #include <linux/if_tun.h>
+ #else
++      #include <netinet/if_ether.h>
+ #ifdef _DFBSD
+       #include <net/tun/if_tun.h>
+ #else
diff --git a/package/aiccu/0004-if-ether-header.patch b/package/aiccu/0004-if-ether-header.patch
deleted file mode 100644 (file)
index 48e8ceb..0000000
+++ /dev/null
@@ -1,23 +0,0 @@
-musl does not allow using <netinet/*> together with <linux/*> headers.
-Since there are both netinet/if_ether.h and linux/if_ether.h providing
-the same definitions, use linux/if_ether.h whenever other linux/*
-headers are included.
-
-Signed-off-by: Alex Suykov <alex.suykov@gmail.com>
-
---- aiccu/common/common.h
-+++ aiccu/common/common.h
-@@ -91,11 +91,12 @@
-       #include <sys/select.h>
-       #include <net/if.h>
--      #include <netinet/if_ether.h>
- #ifdef linux
-       #include <netpacket/packet.h>
-+      #include <linux/if_ether.h>
-       #include <linux/if_tun.h>
- #else
-+      #include <netinet/if_ether.h>
- #ifdef _DFBSD
-       #include <net/tun/if_tun.h>
- #else