package/wmctrl: x-includes and x-libraries must be set for cross-compiling
authorRomain Naour <romain.naour@gmail.com>
Tue, 17 Apr 2018 18:22:08 +0000 (20:22 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 18 Apr 2018 09:46:48 +0000 (11:46 +0200)
set x-includes and x-libraries configure option for cross-compiling.
wmctrl can use poisoned paths if these options are not passed to
configure script.

Fixes:
http://autobuild.buildroot.net/results/7e5/7e5cba8a5650a00e10d1a5528f38cb2bf772aee1

Signed-off-by: Romain Naour <romain.naour@gmail.com>
Cc: Jérôme Pouiller <jezz@sysmic.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/wmctrl/wmctrl.mk

index 0d4aeebc1d3883d8c5b5a7a7f62f056bb4dc4121..36ad3513ff25501ae4808878a3b2ac8da0c717b3 100644 (file)
@@ -11,4 +11,8 @@ WMCTRL_LICENSE_FILES = COPYING
 
 WMCTRL_DEPENDENCIES = libglib2 xlib_libX11 xlib_libXmu
 
+WMCTRL_CONF_OPTS = \
+       --x-includes=$(STAGING_DIR)/usr/include \
+       --x-libraries=$(STAGING_DIR)/usr/lib
+
 $(eval $(autotools-package))