squid: bump to version 3.5.1
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Tue, 27 Jan 2015 14:50:19 +0000 (11:50 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 27 Jan 2015 16:06:15 +0000 (17:06 +0100)
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/squid/0001-assume-get-certificate-ok.patch [new file with mode: 0644]
package/squid/0002-missing-include-time_h.patch [new file with mode: 0644]
package/squid/squid-01-assume-get-certificate-ok.patch [deleted file]
package/squid/squid-02-missing-include-time_h.patch [deleted file]
package/squid/squid.hash
package/squid/squid.mk

diff --git a/package/squid/0001-assume-get-certificate-ok.patch b/package/squid/0001-assume-get-certificate-ok.patch
new file mode 100644 (file)
index 0000000..e26b50d
--- /dev/null
@@ -0,0 +1,17 @@
+The openssl get_certificate working test isn't cross compile friendly.
+Just assume it works ok since we're using a modern OpenSSL version.
+
+Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
+
+diff -Nura squid-3.5.1.orig/configure.ac squid-3.5.1/configure.ac
+--- squid-3.5.1.orig/configure.ac      2015-01-27 11:09:15.035711981 -0300
++++ squid-3.5.1/configure.ac   2015-01-27 11:09:25.829084482 -0300
+@@ -1342,7 +1342,7 @@
+     AC_DEFINE(USE_OPENSSL,1,[OpenSSL support is available])
+     # check for other specific broken implementations
+-    SQUID_CHECK_OPENSSL_GETCERTIFICATE_WORKS
++    #SQUID_CHECK_OPENSSL_GETCERTIFICATE_WORKS
+     SQUID_CHECK_OPENSSL_CONST_SSL_METHOD
+     SQUID_CHECK_OPENSSL_TXTDB
+     SQUID_CHECK_OPENSSL_HELLO_OVERWRITE_HACK
diff --git a/package/squid/0002-missing-include-time_h.patch b/package/squid/0002-missing-include-time_h.patch
new file mode 100644 (file)
index 0000000..18b3ab3
--- /dev/null
@@ -0,0 +1,28 @@
+ipc/Kid.cc: add missing include of time.h
+
+Function time() comes from <time.h>, so add the necessary include.
+This fixes compilation on some configurations, for example
+http://autobuild.buildroot.net/results/b33/b33e1f41e50b6e7ac3e30806b9a617d451bc27b4/
+
+Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
+Upstream-status: submitted (http://bugs.squid-cache.org/show_bug.cgi?id=3967)
+
+---
+ src/ipc/Kid.cc |  4 ++++
+ 1 files changed, 4 insertions(+), 0 deletions(-)
+
+
+diff --git a/src/ipc/Kid.cc b/src/ipc/Kid.cc
+--- a/src/ipc/Kid.cc
++++ b/src/ipc/Kid.cc
+@@ -11,6 +11,10 @@
+ #include <sys/wait.h>
+ #endif
++#if HAVE_TIME_H
++#include <time.h>
++#endif
++
+ int TheProcessKind = pkOther;
+ Kid::Kid():
diff --git a/package/squid/squid-01-assume-get-certificate-ok.patch b/package/squid/squid-01-assume-get-certificate-ok.patch
deleted file mode 100644 (file)
index 0f8d93e..0000000
+++ /dev/null
@@ -1,16 +0,0 @@
-The openssl get_certificate working test isn't cross compile friendly.
-Just assume it works ok since we're using a modern OpenSSL version.
-
-Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
-
-diff -Nura squid-3.3.8.orig/configure.ac squid-3.3.8/configure.ac
---- squid-3.3.8.orig/configure.ac      2013-07-26 08:57:50.177259534 -0300
-+++ squid-3.3.8/configure.ac   2013-07-26 08:57:55.997448040 -0300
-@@ -1265,7 +1265,6 @@
- AC_SUBST(SSLLIB)
- if test "x$with_openssl" = "xyes"; then
--SQUID_CHECK_OPENSSL_GETCERTIFICATE_WORKS
- SQUID_CHECK_OPENSSL_CONST_SSL_METHOD
- SQUID_CHECK_OPENSSL_TXTDB
- fi
diff --git a/package/squid/squid-02-missing-include-time_h.patch b/package/squid/squid-02-missing-include-time_h.patch
deleted file mode 100644 (file)
index 18b3ab3..0000000
+++ /dev/null
@@ -1,28 +0,0 @@
-ipc/Kid.cc: add missing include of time.h
-
-Function time() comes from <time.h>, so add the necessary include.
-This fixes compilation on some configurations, for example
-http://autobuild.buildroot.net/results/b33/b33e1f41e50b6e7ac3e30806b9a617d451bc27b4/
-
-Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
-Upstream-status: submitted (http://bugs.squid-cache.org/show_bug.cgi?id=3967)
-
----
- src/ipc/Kid.cc |  4 ++++
- 1 files changed, 4 insertions(+), 0 deletions(-)
-
-
-diff --git a/src/ipc/Kid.cc b/src/ipc/Kid.cc
---- a/src/ipc/Kid.cc
-+++ b/src/ipc/Kid.cc
-@@ -11,6 +11,10 @@
- #include <sys/wait.h>
- #endif
-+#if HAVE_TIME_H
-+#include <time.h>
-+#endif
-+
- int TheProcessKind = pkOther;
- Kid::Kid():
index bc686c10edfd92020552a38ede3903ad32a03b14..a067383a1d264d23dadde14f3fb3e6e0c104eb54 100644 (file)
@@ -1,3 +1,3 @@
-# From http://www.squid-cache.org/Versions/v3/3.4/squid-3.4.11.tar.xz.asc
-md5    e79ddb108d24823da8c1dbc0fc4a31fb        squid-3.4.11.tar.xz
-sha1   7de0949714cda4d3f19073aa846f00768a6f841b        squid-3.4.11.tar.xz
+# From http://www.squid-cache.org/Versions/v3/3.4/squid-3.5.1.tar.xz.asc
+md5    b3c9d9726314c1136b7a4c06447db24b        squid-3.5.1.tar.xz
+sha1   a2b01afd33d1df3a234e1a5c3405d626f6cf0fb0        squid-3.5.1.tar.xz
index 0bf516f8a8dd83d7838fcead28a301ac6af47246..deb9360c067864a6d12cb4b23c2f7587eff8e55b 100644 (file)
@@ -4,8 +4,8 @@
 #
 ################################################################################
 
-SQUID_VERSION_MAJOR = 3.4
-SQUID_VERSION = $(SQUID_VERSION_MAJOR).11
+SQUID_VERSION_MAJOR = 3.5
+SQUID_VERSION = $(SQUID_VERSION_MAJOR).1
 SQUID_SOURCE = squid-$(SQUID_VERSION).tar.xz
 SQUID_SITE = http://www.squid-cache.org/Versions/v3/$(SQUID_VERSION_MAJOR)
 SQUID_LICENSE = GPLv2+