core/pkg-infra: add missing step hooks
authorYann E. MORIN <yann.morin.1998@free.fr>
Sat, 28 Apr 2018 20:53:04 +0000 (22:53 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 13 May 2018 21:18:51 +0000 (23:18 +0200)
Also call the step hooks from the three steps they are currently not
called in:
  - download,
  - actual download (when main archive is not the real source, like
    external toolchains),
  - rsync (for local or override-srcdir).

Reported-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/pkg-generic.mk

index 8a3b5f90a9a2b90c83ca5275f72712814716e609..387762b0944e0b8b847191c57683f9d29be2761e 100644 (file)
@@ -132,6 +132,7 @@ endif
 
 # Retrieve the archive
 $(BUILD_DIR)/%/.stamp_downloaded:
+       @$(call step_start,download)
        $(foreach hook,$($(PKG)_PRE_DOWNLOAD_HOOKS),$(call $(hook))$(sep))
 # Only show the download message if it isn't already downloaded
        $(Q)for p in $($(PKG)_ALL_DOWNLOADS); do \
@@ -143,12 +144,15 @@ $(BUILD_DIR)/%/.stamp_downloaded:
        $(foreach p,$($(PKG)_ALL_DOWNLOADS),$(call DOWNLOAD,$(p))$(sep))
        $(foreach hook,$($(PKG)_POST_DOWNLOAD_HOOKS),$(call $(hook))$(sep))
        $(Q)mkdir -p $(@D)
+       @$(call step_end,download)
        $(Q)touch $@
 
 # Retrieve actual source archive, e.g. for prebuilt external toolchains
 $(BUILD_DIR)/%/.stamp_actual_downloaded:
+       @$(call step_start,actual-download)
        $(call DOWNLOAD,$($(PKG)_ACTUAL_SOURCE_SITE)/$($(PKG)_ACTUAL_SOURCE_TARBALL))
        $(Q)mkdir -p $(@D)
+       @$(call step_end,actual-download)
        $(Q)touch $@
 
 # Unpack the archive
@@ -167,11 +171,13 @@ $(BUILD_DIR)/%/.stamp_extracted:
 # Rsync the source directory if the <pkg>_OVERRIDE_SRCDIR feature is
 # used.
 $(BUILD_DIR)/%/.stamp_rsynced:
+       @$(call step_start,rsync)
        @$(call MESSAGE,"Syncing from source dir $(SRCDIR)")
        $(foreach hook,$($(PKG)_PRE_RSYNC_HOOKS),$(call $(hook))$(sep))
        @test -d $(SRCDIR) || (echo "ERROR: $(SRCDIR) does not exist" ; exit 1)
        rsync -au --chmod=u=rwX,go=rX $(RSYNC_VCS_EXCLUSIONS) $($(PKG)_OVERRIDE_SRCDIR_RSYNC_EXCLUSIONS) $(call qstrip,$(SRCDIR))/ $(@D)
        $(foreach hook,$($(PKG)_POST_RSYNC_HOOKS),$(call $(hook))$(sep))
+       @$(call step_end,rsync)
        $(Q)touch $@
 
 # Patch