dhcpcd: do not pass --target option
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 21 Oct 2014 20:27:07 +0000 (22:27 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 6 Nov 2014 23:04:10 +0000 (00:04 +0100)
dhcpcd is using $(BR2_GCC_TARGET_ARCH) as the value of its --target
option. However, depending on the architecture, this value might be
empty.

After inspecting the dhcpcd configure script, it turns out that in
fact the --target option has the following semantic:

  --target=TARGET   configure for building compilers for TARGET [HOST]

So it is very much like the --target option of regular,
autoconf-based, configure scripts. Since dhcpcd is not a compiler,
passing --target is pointless. Moreover, as long as --os=linux is
passed, passing --host or --target is completely ignored by the
configure script.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/dhcpcd/dhcpcd.mk

index f4b821af2f1a4cd3d52aaa6d5e96db520efa64c9..3bb7a135f8c9716e1d34137dd83ca96b9401bbad 100644 (file)
@@ -25,7 +25,6 @@ endif
 define DHCPCD_CONFIGURE_CMDS
        (cd $(@D); \
        $(TARGET_CONFIGURE_OPTS) ./configure \
-               --target=$(BR2_GCC_TARGET_ARCH) \
                --os=linux \
                $(DHCPCD_CONFIG_OPTS) )
 endef