Get rid of the OPTIMIZE_FOR_CPU variable
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 10 Apr 2010 21:50:45 +0000 (23:50 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 11 Apr 2010 19:10:35 +0000 (21:10 +0200)
This variable, together with the FIXME comment, has been added has
part of Eric Andersen's « Major buildroot facelift, step one » commit
that occured in October 2004.

Since then, no real usage has been made of OPTIMIZE_FOR_CPU, and the
initial intention has probably been lost in the memories of the
implementors.

Therefore, get rid of the variable, and just use $(ARCH) at the two
locations the variable was used.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Makefile.in
toolchain/Makefile.in

index 43ff2ddad70360c650938aade44bfa1bab496e59..983caf38e3a7ec3285f969d04e5112590c982aa0 100644 (file)
@@ -109,8 +109,8 @@ TOOLCHAIN_DIR=$(BASE_DIR)/toolchain
 
 # Quotes are needed for spaces et al in path components.
 TARGET_PATH="$(TOOLCHAIN_DIR)/bin:$(HOST_DIR)/bin:$(HOST_DIR)/usr/bin:$(HOST_DIR)/usr/sbin/:$(STAGING_DIR)/bin:$(STAGING_DIR)/usr/bin:$(PATH)"
-GNU_TARGET_NAME=$(OPTIMIZE_FOR_CPU)-linux
-REAL_GNU_TARGET_NAME=$(OPTIMIZE_FOR_CPU)$(GNU_TARGET_SUFFIX)
+GNU_TARGET_NAME=$(ARCH)-linux
+REAL_GNU_TARGET_NAME=$(ARCH)$(GNU_TARGET_SUFFIX)
 TARGET_CROSS=$(STAGING_DIR)/usr/bin/$(REAL_GNU_TARGET_NAME)-
 KERNEL_CROSS=$(TARGET_CROSS)
 else ifeq ($(BR2_TOOLCHAIN_EXTERNAL),y)
index 91aa17af619e3e811095a448db9d3ea2112d4676..57d84a3e7656270b4eabb59bfd7db01bd44166c7 100644 (file)
@@ -30,8 +30,5 @@ BR2_SYSROOT=# nothing
 BR2_ISYSROOT=#nothing
 endif
 
-# FIXME -- this is temporary
-OPTIMIZE_FOR_CPU=$(ARCH)
-
 # gcc has a bunch of needed stuff....
 include toolchain/gcc/Makefile.in