faifa: force GIT_REV to a correct value
authorMaxime Hadjinlian <maxime.hadjinlian@gmail.com>
Tue, 10 Jun 2014 22:15:57 +0000 (00:15 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 11 Jun 2014 11:12:25 +0000 (13:12 +0200)
This variable is looked up by the Makefile throught a git command line
invocation.
Since we don't keep the '.git' folder in the packages when we clone
them, the command line fail to find anything.

Even worse, it can keep going up the tree until it finds buildroot's
'.git' directory.

Signed-off-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/faifa/faifa.mk

index 8f5d258c6cb7c952f29484f3d58ff5aa42889117..c83b02a3eac610bb5039d08c73399c74b2edb9de 100644 (file)
@@ -11,6 +11,8 @@ FAIFA_DEPENDENCIES = libpcap host-autoconf
 FAIFA_LICENSE = GPLv2+
 FAIFA_LICENSE_FILES = COPYING
 
+FAIFA_MAKE_OPT += GIT_REV=$(FAIFA_VERSION)
+
 # This package uses autoconf, but not automake, so we need to call
 # their special autogen.sh script, and have custom target and staging
 # installation commands.