package/exiv2: fix pthread detection
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 4 Jun 2017 08:27:14 +0000 (10:27 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 5 Jun 2017 09:51:56 +0000 (11:51 +0200)
This commit fixes an error during configure:

-- Check if compiler accepts -pthread
CMake Error: TRY_RUN() invoked in cross-compiling mode, please set the
 following cache variables appropriately:
   THREADS_PTHREAD_ARG (advanced)

Patch ported from librtlsdr:
https://git.busybox.net/buildroot/commit/?id=4c6eace6f756d15ae9639a503c9245d1e7fb12a9

Fixes
http://autobuild.buildroot.net/results/0f9/0f985993a0c0076f027cfe25bb13d6b85c644c0d/

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/exiv2/exiv2.mk

index f56e861222bfe5db05654d678c9692c9ce6d2c46..bdd40f7f4f377a4659d89c51f3af29a04c47597d 100644 (file)
@@ -11,6 +11,10 @@ EXIV2_INSTALL_STAGING = YES
 
 EXIV2_CONF_OPTS += -DEXIV2_ENABLE_BUILD_SAMPLES=OFF
 
+# The following CMake variable disables a TRY_RUN call in the -pthread
+# test which is not allowed when cross-compiling.
+EXIV2_CONF_OPTS += -DTHREADS_PTHREAD_ARG=OFF
+
 ifeq ($(BR2_PACKAGE_EXIV2_LENSDATA),)
 EXIV2_CONF_OPTS += -DEXIV2_ENABLE_LENSDATA=OFF
 endif