package/easydbus: new package
authorMarcin Niestroj <m.niestroj@grinn-global.com>
Wed, 7 Dec 2016 14:49:05 +0000 (15:49 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 7 Dec 2016 17:16:42 +0000 (18:16 +0100)
Signed-off-by: Marcin Niestroj <m.niestroj@grinn-global.com>
Reviewed-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/Config.in
package/easydbus/Config.in [new file with mode: 0644]
package/easydbus/easydbus.hash [new file with mode: 0644]
package/easydbus/easydbus.mk [new file with mode: 0644]

index 664d0d96e123745e558f81a3523260e72c6b1f40..c14575c4c44e6c6e5dea4b6c5d3b8d70f104b4d5 100644 (file)
@@ -521,6 +521,7 @@ menu "Lua libraries/modules"
        source "package/cosmo/Config.in"
        source "package/coxpcall/Config.in"
        source "package/dado/Config.in"
+       source "package/easydbus/Config.in"
        source "package/lbase64/Config.in"
        source "package/ljlinenoise/Config.in"
        source "package/ljsyscall/Config.in"
diff --git a/package/easydbus/Config.in b/package/easydbus/Config.in
new file mode 100644 (file)
index 0000000..51519d6
--- /dev/null
@@ -0,0 +1,14 @@
+config BR2_PACKAGE_EASYDBUS
+       bool "easydbus"
+       select BR2_PACKAGE_LIBGLIB2
+       depends on BR2_USE_WCHAR # libglib2
+       depends on BR2_TOOLCHAIN_HAS_THREADS # libglib2
+       depends on BR2_USE_MMU # libglib2
+       help
+         Easy to use DBus library for Lua.
+
+         https://github.com/mniestroj/easydbus
+
+comment "easydbus needs a toolchain w/ wchar, threads"
+       depends on BR2_USE_MMU
+       depends on !BR2_USE_WCHAR || !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/easydbus/easydbus.hash b/package/easydbus/easydbus.hash
new file mode 100644 (file)
index 0000000..0ef73f2
--- /dev/null
@@ -0,0 +1,2 @@
+# Locally calculated
+sha256 3e5907664f5dfebbc0e652faf87564fd58dbd639742f442c100ef2db8be46e52 easydbus-59c340f2cd2c92ded82f9d4436866847f295faab.tar.gz
diff --git a/package/easydbus/easydbus.mk b/package/easydbus/easydbus.mk
new file mode 100644 (file)
index 0000000..376b09b
--- /dev/null
@@ -0,0 +1,13 @@
+################################################################################
+#
+# easydbus
+#
+################################################################################
+
+EASYDBUS_VERSION = 59c340f2cd2c92ded82f9d4436866847f295faab
+EASYDBUS_SITE = $(call github,mniestroj,easydbus,$(EASYDBUS_VERSION))
+EASYDBUS_DEPENDENCIES = luainterpreter libglib2
+EASYDBUS_LICENSE = MIT
+EASYDBUS_LICENSE_FILES = LICENSE
+
+$(eval $(cmake-package))