mdadm: move from /usr/sbin to /sbin
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 14 Oct 2018 20:00:55 +0000 (22:00 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 15 Oct 2018 05:20:42 +0000 (07:20 +0200)
The upstream Makefile by default installs to /sbin but we override
that to install it in /usr/sbin. Since mdadm is a pretty core utility
for the boot process, it makes sense to comply with upstream's default
behavior, so we change mdadm.mk to install mdadm in /sbin. This also
removes the somewhat non-standard DESTDIR value.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/mdadm/mdadm.mk

index 6efade981d9fd0cfb34e6d27a3f4b3f571968886..bdf77fcd56d4e7baf60fc4f4fa6f6ef497f2503a 100644 (file)
@@ -14,14 +14,14 @@ define MDADM_BUILD_CMDS
        $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) \
                $(TARGET_CONFIGURE_OPTS) \
                CFLAGS="$(TARGET_CFLAGS) -DNO_COROSYNC -DNO_DLM" \
-               CPPFLAGS="$(TARGET_CPPFLAGS) -DBINDIR=\\\"/usr/sbin\\\"" \
+               CPPFLAGS="$(TARGET_CPPFLAGS) -DBINDIR=\\\"/sbin\\\"" \
                CHECK_RUN_DIR=0 \
                mdadm
 endef
 
 define MDADM_INSTALL_TARGET_CMDS
        $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) \
-               DESTDIR=$(TARGET_DIR)/usr \
+               DESTDIR=$(TARGET_DIR) \
                install-mdadm
 endef