- default to mips I for mipsel and mips III for mips
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Tue, 2 Oct 2007 21:36:49 +0000 (21:36 -0000)
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Tue, 2 Oct 2007 21:36:49 +0000 (21:36 -0000)
- suggest some target flags for abi64

package/Makefile.in
target/Config.in.arch

index 0c2abcb1d8c4a7242a483b9c28dd25862a5d02e8..903f46d6d6541af02d2df49f2e7a2a2879f473bf 100644 (file)
@@ -51,6 +51,10 @@ ifeq ($(findstring y,$(BR2_sparc_v9a)$(BR2_sparc64_v9a)$(BR2_sparc_v9b)$(BR2_spa
 TARGET_CFLAGS+=-mvis
 endif
 
+ifeq ($(findstring yy,$(BR2_mips)$(BR2_MIPS_ABI64)),yy)
+TARGET_CFLAGS+=-fno-pic -mno-abicalls
+endif
+
 TARGET_CXXFLAGS=$(TARGET_CFLAGS)
 
 # else it's an external toolchain
index 367dd59b44a5167f5d68b8197e34efdb5b8ee73c..d764b62dd0cf8a29c7b0479c7114f0a56f90a142 100644 (file)
@@ -124,9 +124,13 @@ endchoice
 choice
        prompt "Target Architecture Variant"
        depends BR2_mips || BR2_mipsel
-       default BR2_mips_3
+       default BR2_mips_3 if BR2_mips
+       default BR2_mips_1 if BR2_mipsel
        help
          Specific CPU variant to use
+         
+         64bit cabable: 3, 4, 64, 64r2
+         non-64bit capable: 1, 2, 32, 32r2
 
 config BR2_mips_1
        bool "mips I (generic)"