gpsd: adjust udev rules file permissions
authorJames Knight <james.knight@rockwellcollins.com>
Thu, 5 Nov 2015 18:41:53 +0000 (13:41 -0500)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 5 Nov 2015 21:16:03 +0000 (22:16 +0100)
Adjust a generated udev rule file (25-gpsd.rules) to have user write
permissions. This is to prevent rebuild issues when the gpsd package
fails to re-install on a target (since the `cp` of the rule file will
fail due to permissions).

[Thomas: minor tweaks to code comments and commit title.]

Signed-off-by: James Knight <james.knight@rockwellcollins.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/gpsd/gpsd.mk

index 577b43cfcc1bb008920dcdac7d49a3d03232a3db..87911c3905fe5669b1116d0d5858adfc888d9c4c 100644 (file)
@@ -217,6 +217,8 @@ define GPSD_INSTALL_STAGING_CMDS
                install)
 endef
 
+# After installing the udev rule, make it writable so that this
+# package can be re-built/re-installed.
 ifeq ($(BR2_PACKAGE_HAS_UDEV),y)
 define GPSD_INSTALL_UDEV_RULES
        (cd $(@D); \
@@ -225,6 +227,7 @@ define GPSD_INSTALL_UDEV_RULES
                $(SCONS) \
                $(GPSD_SCONS_OPTS) \
                udev-install)
+       chmod u+w $(TARGET_DIR)/lib/udev/rules.d/25-gpsd.rules
 endef
 
 GPSD_POST_INSTALL_TARGET_HOOKS += GPSD_INSTALL_UDEV_RULES