toolchain/buildroot: glibc does not always have native RPC
authorYann E. MORIN <yann.morin.1998@free.fr>
Tue, 29 Dec 2020 21:10:30 +0000 (22:10 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 29 Dec 2020 21:13:11 +0000 (22:13 +0100)
Starting with glibc-2.32, the RPC code has been removed from
glibc [0], and it is not possible anymore to enable it, even
with the --enable-obsolete-rpc configure option (which was
also removed).

riscv32 and arc both use a glibc 2.32+ so do not forcefully
enable native RPC for them.

Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
Cc: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
toolchain/toolchain-buildroot/Config.in

index 2058ff1eb9b1879de929213b309aedbca61cde14..019495accf753d3333111ad2dad9aa8e70df7493 100644 (file)
@@ -59,8 +59,9 @@ config BR2_TOOLCHAIN_BUILDROOT_GLIBC
        depends on !BR2_powerpc_SPE
        depends on BR2_RISCV_ISA_RVA || !BR2_riscv
        select BR2_TOOLCHAIN_USES_GLIBC
-       # our glibc.mk enables RPC support
-       select BR2_TOOLCHAIN_HAS_NATIVE_RPC
+       # our glibc.mk enables RPC support, except for riscv32 and arc
+       # that don't have it anymore (glibc 2.32+)
+       select BR2_TOOLCHAIN_HAS_NATIVE_RPC if !BR2_RISCV_32 && !BR2_arc
        help
          This option selects glibc as the C library for the
          cross-compilation toolchain.