uClibc: add uClibc 0.9.30 to kconfig and Makefile
authorHans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>
Mon, 1 Dec 2008 13:02:22 +0000 (13:02 -0000)
committerHans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>
Mon, 1 Dec 2008 13:02:22 +0000 (13:02 -0000)
This patch adds uClibc versino 0.9.30 to the list of selectable versions. The
version identification for snapshot is also updated to reflect 0.9.30.

Signed-off-by: Hans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>
toolchain/uClibc/Config.in
toolchain/uClibc/uclibc.mk

index 4af60ea4f089f321ee0ce7958faf2a94d7f94f7c..83a53432a7bcc2403a244aaa3661c2bec4f70827 100644 (file)
@@ -18,6 +18,10 @@ choice
                bool "uClibc 0.9.29"
                depends on BR2_EXT_UCLIBC_VERSION_0_9_29
 
+       config BR2_UCLIBC_VERSION_0_9_30
+               bool "uClibc 0.9.30"
+               depends on BR2_EXT_UCLIBC_VERSION_0_9_30
+
        config BR2_UCLIBC_VERSION_SNAPSHOT
                bool "daily snapshot"
 
index 45b57ce03c36ae73f92e3f2fe7f27ecdc5d4aefa..480d48ea4627ab421b9c1ed3eaf4d3738ce71f4a 100644 (file)
@@ -15,7 +15,7 @@ endif
 
 ifeq ($(BR2_UCLIBC_VERSION_SNAPSHOT),y)
 # Be aware that this changes daily....
-UCLIBC_VER:=0.9.29
+UCLIBC_VER:=0.9.30
 UCLIBC_DIR:=$(TOOL_BUILD_DIR)/uClibc
 UCLIBC_SOURCE:=uClibc-$(strip $(subst ",, $(BR2_USE_UCLIBC_SNAPSHOT))).tar.bz2
 #"))
@@ -23,6 +23,9 @@ UCLIBC_SITE:=http://www.uclibc.org/downloads/snapshots
 UCLIBC_PATCH_DIR:=toolchain/uClibc/
 else
 # releases
+ifeq ($(BR2_UCLIBC_VERSION_0_9_30),y)
+UCLIBC_VER:=0.9.30
+endif
 ifeq ($(BR2_UCLIBC_VERSION_0_9_29),y)
 UCLIBC_VER:=0.9.29
 endif