quagga: fix build breakage without snmp
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Thu, 18 Apr 2013 01:47:21 +0000 (01:47 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 21 Apr 2013 20:33:27 +0000 (22:33 +0200)
Quagga no longer supports explicitly disabling snmp, and what's worse,
it interprets --disable-snmp as --enable-snmp.
Remove the disable configure option.
While at it add a comment about net-snmp requiring AgentX support for
quagga to build properly as suggested by Arnout.
Fixes:
http://autobuild.buildroot.net/results/a9bce6dd8065ddb1850a4e14f0e4eb257ee89286/

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/quagga/Config.in
package/quagga/quagga.mk

index 0834201d4de0a1b19a62dd378e745cce18b2095b..c364ae1b4bb874aea3d93330cb34f9745f72258c 100644 (file)
@@ -84,4 +84,7 @@ config BR2_PACKAGE_QUAGGA_SNMP
        help
          Make quagga information available via SNMP SMUX.
 
+comment "AgentX support must be enabled in net-snmp or the build will break"
+       depends on BR2_PACKAGE_QUAGGA_SNMP
+
 endif
index 42f8506b245353316c90a9bf09b73e857ad1115c..347ec4ddb5626201eefb47c6bf1c94cbdc84c6ff 100644 (file)
@@ -26,10 +26,8 @@ QUAGGA_CONF_OPT += $(if $(BR2_PACKAGE_QUAGGA_OPAQUE_LSA),--enable-opaque-lsa,--d
 
 ifeq ($(BR2_PACKAGE_QUAGGA_SNMP),y)
 QUAGGA_CONF_ENV += ac_cv_path_NETSNMP_CONFIG=$(STAGING_DIR)/usr/bin/net-snmp-config
-QUAGGA_CONF_OPT += --enable-snmp
+QUAGGA_CONF_OPT += --enable-snmp=agentx
 QUAGGA_DEPENDENCIES += netsnmp
-else
-QUAGGA_CONF_OPT +=--disable-snmp
 endif
 
 $(eval $(autotools-package))