poppler: Add option for Qt5 support
authorJens Kleintje <jkleintje@ultratronik.de>
Sat, 11 Feb 2017 11:05:30 +0000 (12:05 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 11 Feb 2017 14:19:48 +0000 (15:19 +0100)
Add an option to build the libpoppler-qt5 library.

Signed-off-by: Andreas Naumann <anaumann@ultratronik.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/poppler/Config.in
package/poppler/poppler.mk

index 2ca3ff62b57ca2f327169fd1199a034fa74e2302..d741f65287e92d78b63c65db4539d194d01e6fae 100644 (file)
@@ -24,6 +24,15 @@ config BR2_PACKAGE_POPPLER_QT
 comment "poppler Qt support needs a toolchain not affected by Binutils bug 19405"
        depends on BR2_TOOLCHAIN_HAS_BINUTILS_BUG_19405
 
+config BR2_PACKAGE_POPPLER_QT5
+       bool "Qt5 support"
+       depends on BR2_PACKAGE_QT5
+       select BR2_PACKAGE_QT5BASE_GUI
+       select BR2_PACKAGE_QT5BASE_WIDGETS
+       select BR2_PACKAGE_QT5BASE_XML
+       help
+         Build Qt support into the Poppler library
+
 endif
 
 comment "poppler needs a toolchain w/ C++, threads"
index 3e8a9f4c36a3e047ce028001b398ad191d600486..022c2c5e99b8e2a5cd6129c991b85d6213f554be 100644 (file)
@@ -87,6 +87,13 @@ else
 POPPLER_CONF_OPTS += --disable-poppler-qt4
 endif
 
+ifeq ($(BR2_PACKAGE_POPPLER_QT5),y)
+POPPLER_DEPENDENCIES += qt5base
+POPPLER_CONF_OPTS += --enable-poppler-qt5
+else
+POPPLER_CONF_OPTS += --disable-poppler-qt5
+endif
+
 ifeq ($(BR2_PACKAGE_OPENJPEG),y)
 POPPLER_DEPENDENCIES += openjpeg
 POPPLER_CONF_OPTS += --enable-libopenjpeg