package/racehound: require kernel modules from Kconfig
authorYann E. MORIN <yann.morin.1998@free.fr>
Thu, 10 Dec 2015 18:53:16 +0000 (19:53 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 29 Dec 2015 22:51:57 +0000 (23:51 +0100)
And reorder 'select' after 'depends'

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/racehound/Config.in
package/racehound/racehound.mk

index b9c4f364c156db84c1c6b31f85da05511d85bbfe..9f1011bf0e4025b325bbb35d8b027766d6593fcd 100644 (file)
@@ -1,6 +1,5 @@
 config BR2_PACKAGE_RACEHOUND
        bool "racehound"
-       select BR2_PACKAGE_ELFUTILS
        depends on BR2_LINUX_KERNEL
        depends on BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_14
        depends on BR2_INSTALL_LIBSTDCPP
@@ -9,6 +8,8 @@ config BR2_PACKAGE_RACEHOUND
        depends on BR2_TOOLCHAIN_USES_UCLIBC || BR2_TOOLCHAIN_USES_GLIBC # elfutils
        # only x86/x86_64 supported
        depends on BR2_i386 || BR2_x86_64
+       select BR2_PACKAGE_ELFUTILS
+       select BR2_LINUX_NEEDS_MODULES # not using kernel-module infra
        help
          RaceHound can be used to detect data races in the Linux
          kernel on x86.
index 66f3ebec36a0b4b481cde1c773539c043a6f82de..7d8d1e3542e4cee8b40f1241a680fefee9de7563 100644 (file)
@@ -12,12 +12,6 @@ RACEHOUND_SUPPORTS_IN_SOURCE_BUILD = NO
 
 RACEHOUND_DEPENDENCIES = elfutils linux
 
-# We're building a kernel module without using the kernel-module infra,
-# so we need to tell we want module support in the kernel
-ifeq ($(BR2_PACKAGE_RACEHOUND),y)
-LINUX_NEEDS_MODULES = y
-endif
-
 # override auto detection (uses host parameters, not cross compile
 # ready)
 RACEHOUND_CONF_OPTS += \