imx-usb-loader: new host package
authorAntoine Ténart <antoine.tenart@free-electrons.com>
Fri, 1 May 2015 16:15:40 +0000 (18:15 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 2 May 2015 07:47:04 +0000 (09:47 +0200)
This host package allows to build tools to download and execute code on
Freescale i.MX5/i.MX6 and Vybrid SoCs through the Serial Download
Protocol.

The work behind this commit was funded by ECA Group
<http://www.ecagroup.com>. ECA Group is the copyright owner of the
contributed code.

Signed-off-by: Antoine Tenart <antoine.tenart@free-electrons.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in.host
package/imx-usb-loader/Config.in.host [new file with mode: 0644]
package/imx-usb-loader/imx-usb-loader.mk [new file with mode: 0644]

index 94981adb6425c7ab86bef9ba8932d36b029f8ca0..051bc4a137a671edd57d056962839fb422a7cbfe 100644 (file)
@@ -10,6 +10,7 @@ menu "Host utilities"
        source "package/genext2fs/Config.in.host"
        source "package/genimage/Config.in.host"
        source "package/genpart/Config.in.host"
+       source "package/imx-usb-loader/Config.in.host"
        source "package/lpc3250loader/Config.in.host"
        source "package/mke2img/Config.in.host"
        source "package/mtd/Config.in.host"
diff --git a/package/imx-usb-loader/Config.in.host b/package/imx-usb-loader/Config.in.host
new file mode 100644 (file)
index 0000000..aefa01b
--- /dev/null
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_HOST_IMX_USB_LOADER
+       bool "host-imx-usb loader"
+       depends on BR2_arm
+       help
+         This package contains tools to download and execute code
+         on Freescale i.MX5/i.MX6 and Vybrid SoCs through the
+         Serial Download Protocol.
+
+         https://github.com/boundarydevices/imx_usb_loader
diff --git a/package/imx-usb-loader/imx-usb-loader.mk b/package/imx-usb-loader/imx-usb-loader.mk
new file mode 100644 (file)
index 0000000..4b60505
--- /dev/null
@@ -0,0 +1,22 @@
+################################################################################
+#
+# imx-usb-loader
+#
+################################################################################
+
+IMX_USB_LOADER_VERSION = f96aee286ea17c832b7ec922dd76842deb5ce299
+IMX_USB_LOADER_SITE = $(call github,boundarydevices,imx_usb_loader,$(IMX_USB_LOADER_VERSION))
+IMX_USB_LOADER_LICENSE = LGPLv2.1+
+IMX_USB_LOADER_LICENSE_FILES = COPYING
+IMX_USB_LOADER_DEPENDENCIES = host-libusb
+
+define HOST_IMX_USB_LOADER_BUILD_CMDS
+       $(HOST_MAKE_ENV) $(MAKE) -C $(@D)
+endef
+
+define HOST_IMX_USB_LOADER_INSTALL_CMDS
+       $(HOST_MAKE_ENV) $(MAKE) -C $(@D) \
+               DESTDIR=$(HOST_DIR) sysconfdir=/etc install
+endef
+
+$(eval $(host-generic-package))